Easel crashes my Firefox, locks up my IE. Do I need Chrome?

I just ordered the X-carve and thought I’d check out Easel while waiting for it to arrive.

I managed to sign in on Firefox, but about 2 seconds after the initial Easel screen comes up FF crashes. I did that a few times with the same results, so then I tried IE. On IE it ran very sluggish but after a few minutes it managed to get past the initial screen to actually load a demo file. Then it just grayed out and gave me the “not responding” error.

I’ve closed all other programs and tabs and still get the same result.

Does easel only run decently on Chrome or some other browser? Is it just because it’s Saturday morning and the entire CNC community is out in their garages making widgets? Or is it me?

I’m running Windows 7, 4 gig ram. My internet connection is rural wi-fi at about 6Mbps.

Thanks in advance for any help.

It works the best in Chrome. It is not designed for IE.

On Firefox do you have WebGL enabled?

I didn’t have it enabled. I just enabled it though, closed FF, opened FF, opened Easel, watched FF crash again. I’ll download Chrome later this afternoon and see if it works for me there.

What version of FF are you using?

FF 37.0.2

I’m OK now - I just downloaded Chrome and it works fine there. I’ll only use it for the CNC so I just set the homepage to Easel. It seems to work fast and hasn’t crashed as I play with it.

Anxiously waiting for my X-Carve to be delivered!!! :smiley:
I am having the same problem. I get the blue screen of death everytime I try to access Easel. I tried Chrome and the same thing happens. It does take a little longer to crash with Chrome, but still does.

I wish I could help you but I’ve been exploring other software. I’ve had good luck with Makercam so far and I think I’m going to order the desktop version of Cut2D or V-Carve and then output their g-code to Universal G-Code Sender (UGS). OpenSCam is a great (free) preview program.

I did get easel to run in Chrome without crashing, but I couldn’t it to run like in any of the tutorials. I’d select walnut for the material but for the display all I’d get for previewing toolpaths would be some blue/red lines on a white background.

I’ve still got plenty of time to learn. I didn’t even hear about X-Carve until a couple of weeks ago, didn’t order until the 24th of April so I’m way way way way down the list. I’m just hoping I don’t get to the front of the line and the bouncer comes out, closes the velvet rope and says “Sorry, the club is full.”

I too am anxiously awaiting the arrival of my X-Carve. I have been getting familiar with Easel and it seemed great until it just started crashing and then starting back up without the 3d rendering on the right. The drawing area is still there and functional and so are the controls and settings it just does not show the 3d rendering. I have Google Chrome and it worked great for a few days then this happened and I can not get it to work anymore. It also does the same thing on IE. WebGL is enabled. Any suggestions would be greatly appreciated…

What version of each browser are you using?

Chrome version is 42.0.2311.135m
IE version is 11.0.9600.17728
Running Chrome on Windows 7

Both are fully upgraded to the automatically and I even re-installed Google Chorme.
I just turned off my firewall and it worked a little better, but still when I chose a material the screen goes black and I get a message that says WebGL has hit a snag and gives me the option to reload. After reloading there is no 3d material rendering. All else seems to be working properly.

@StephenOgle, @JoeMeyer can you guys both let me know the make / model of computer you are using? You can PM me if you don’t want to post it.

We use a couple different low-powered windows laptops here for testing and have not encountered problems like this. Your computers specs may help shed some light on the issue.

Sorry for the inconvenience. It is hard to ensure compatibility across hundreds of combinations of browsers, operating systems and hardware but we are committed to making Easel work on IE (>=10), Firefox, Safari and Chrome.

Would easel support a chrome book as well?

Hi @PaulKinlaw,

You should be able to use Easel on a chromebook for design, but you will not currently be able to connect to your machine and carve a job. That may change somewhere down the line, but it isn’t supported right now.

Also check to ensure you don’t have any addons installed. I have seen it a few times where addons would cause all browsers to crash when used for an application.

I would go into your Remove Programs application and uninstall all addons and any applications you don’t know what are.

Chrome Version 42.0.2311.135 m (downloaded just to try out easel)
IE: 11.0.9600.17728
FF: 37.0.2 (crashes the browser)
Windows 7 Home Premium with SP1. AMD x2 1.6Ghz processor with 4GB RAM.

Mine is an HP G72 Laptop. It worked just fine for about the first week I used it, then this started.

I saw a reference to someone using artcam express. So far that software looks pretty interesting. Has anyone used it yet and can give some feedback on it?

I downloaded it, but didn’t find it as easy as Cut2D or V-Carve. I deleted it when I looked at the pricing. Don’t let the initial numbers fool you - take a close look at what you get for the basic price, and then go look at the “additional modules” and see how much you have to pay to get their particular functions.

Hmmm glad to know as 149.00 was a very low entry fee. I’ll play with cut 2d some more to see how I like it. Thank you

After re installing Google Chrome I can use Easel to design with and even have the 3D rendering showing the real time changes even changing the size and thickness of the material. However, as soon as I change from the default material (I think birch) I get a black screen. Easel pops back up almost immediately showing the same project but with no 3D rendering. Everything else seems to work perfectly you just can not see the changes on the screen. Also crashes when I try to use another project such as the bottle opener. My X-Carve has not yet shipped and so I have some time to resolve this issue. I may just have to buy a new computer. Hope not. I don’t really have the money for that or another software package to control the X-Carve. Any suggestions are greatly appreciated.