Easel down 2/28/17?

Is easel down? I keep getting a reload page error.

It worked fine for me about 2 hours ago.

Is it working now for anyone?

Not working here.

It’s down here too

We are experiencing some problems with the platform that Easel (and the forum) run on (Amazon Web Services). Amazon is working on these issues, and we are also investigating any options we might have for working around it. We’ll let you know when we have more information.


Nope. Just a blank screen. was working an hour ago.

The POS system my company uses is experiencing failures as well and it runs on same platform

Yeah, 90% of the internet is on it :slight_smile:

1 Like

The project pages are affected as well as you probably already know. :grin:

forums working fine now but easel is still not working

i’m getting the same error

Just when I was on a roll with a design and carve project. Oh well.

Major internet issues in the US today; it’s affecting production systems we have at work as well. This is not an ‘inventables’ issue.

1 Like

Easel should now be available and responsive - however certain features may not work as expected (such as image importing, apps and project thumbnails) while Amazon Web Services are recovering.

1 Like