Easel driver 0.3.5 is not working

I was wondering if anyone else on here has had any success with the new driver. Easel seems to not recognize it. I have restarted, re installed, checked the cords. still nothing. when I click on the carve button, it just keeps saying please install the driver, which of course, I did.

I’m running 0.3.7 with no issues

For me, shortly after setting up Carvey, Easel wouldn’t connect to the machine even though I had done the test cut successfully before. Ended up I just had to reinstall the FTDI drivers and that worked for me, maybe it will in your case as well.

FTDI Drivers:

where do you find this 0.3.7 driver? I am still on 0.3.6

Maybe it was 0.3.6 though I thought there were two above 0.3.5 when I downloaded it. I’ll have to check that PC for sure when I get home.

I’ll let you know.

Thanks guys… i think it may be an issue I can’t solve, as Easel doesn’t recognize the new driver has been installed… maybe its just with mac osx, or some other problem. Easel recognizes nothing more recent than 0.3.2

i have tried 0.3.7 and 0.3.6 drivers on my macs (mac mini and mac book pro, both with mac os 10.12.5) and tried with safari, chrome and firefox. non of it works. in the log file (/Library/Easel/iris.error.log) i see the error below. anyone any idea how to get it working? (my x-carve used to work just fine). i guess i will try 0.3.2

throw err;

Error: Cannot find module ‘./lib/’
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/Library/Easel/iris/node_modules/socket.io/node_modules/socket.io-client/index.js:2:18)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)

yep, 0.3.2 does work in my case

Same with me 0.3.2 works but nothing newer. Must be a mac incompatibility issue.

I just spoke with Easel Support, and they are aware of the issue with mac os, which seems to be in the jscript. Next update should have this solved. Not sure what these updates are improving, but they mentioned the next update will have a new gcode. Still happy with 0.3.2 though.

Any news on this from anyone yet… as I am still unable to use easel for the same reasons (on Mac).


Havent checked. I moved to VCarve. Oh boy this is some hefty programming in contrast to easel. If easel could just do 3d, people would pay for easel pro. Very let down by Easel to be honest. I have a suspicion they are focusing on profit now, which never used to be the case. Thats not to say most of their hardware isnt great, esp since the xcontroller came out. I highly suggest vcarve if you do anything that is complex, 3d, or needs dual tooling.

It pays for istelf quickly. i use a Mac and purchased Parallels as well since vcarve is unix based, runs as if the mac was made for parallels and vcarve. Way bigger learning curve though.