Easel Driver Doesn't Install

Since older drivers are no longer supported, I downloaded the latest driver, unzipped it, and ran the setup program. There was nothing displayed, and Easel still says I need to install a newer driver. What’s going on? I need to get something carved this weekend!

I’ve tried several older versions, all the way back to 0.3.5, the oldest one still supported, but they all do the same thing.

I’ve seen some posts about issues with Win10 upgrades, but that doesn’t apply here. I’m using an old laptop running Vista, and have avoided upgrading it.

I tried installing the Easel driver on a newer laptop, and it appears to have installed correctly, but Easel does not see the device. It was such a long time ago that I don’t remember well, but doesn’t it need a driver for the USB virtual COM port? Where do I find that driver?

OK, I found how to get the USB driver installed (remembering that at the time I thought it was rather stupid that you have to install all of the Arduino IDE just to get this driver - I still think so). I’m up and running, but still not happy because I don’t want to have to use the newer laptop for this, as the shop area is too dusty.

What do you mean by no longer supported?

they are still listed in other downloads


I’ll refer you to this: [Important: Support ending for Easel Driver version 0.3.3 and older on August 19, 2019]. As it says, my old Vista laptop will no longer work, but it’s really because the driver is no longer supported, not because of Microsoft. Yes, the old drivers are still available for download, and you can install them, but since Easel is web-based, it is always the latest version, and will not work with the older drivers.