Easel driver missing?

running a job as i type… no problems with the new driver here…:triumph:

@Heiko, @Inkedmedic, @S_Kuiper, and anyone else who’s having Easel tell you that you need to install the Easel Driver after you’ve already done that—can you send me the Easel Driver’s error log file? (As a private message is fine.)

Mac users: /Library/Easel/iris.error.log (that’s Library in the root of your hard drive, not the one in your user folder)
Windows users: C:\EaselLocal\iris.error.log

@RelabManager, if it’s saying it can’t find your machine, that would be a different problem. Sometimes restarting or plugging into a different USB port can help, but if the problem persists, email help@inventables.com.

/Library/Easel/iris.error.log had a modified timestamp of dec 2016 so I renamed it and reinstalled the driver. Now I have a zero length iris.error.log and still get prompted to install the driver.

Thanks for the info I also have the same problem.

Don’t think there’s anything useful in the log as it’s also timestamped 2 days ago (when things still worked):
DEPRECATION: Please use require(‘serialport’)instead ofrequire(‘serialport’).SerialPortDEPRECATION: Please userequire(‘serialport’)instead ofrequire(‘serialport’).SerialPort`
undefined:0

TypeError: There’s no write queue for that file descriptor (after write)!
at TypeError (native)
DEPRECATION: Please use require('serialport') instead of `require(‘serialport’).SerialPort``

Here’s mine. Mac user… Also file dated sometime in the distant past if that makes a difference.

events.js:141
throw er; // Unhandled ‘error’ event
^

Error: Error Device not configured calling write(…)
at Error (native)

Ok, I found the reason why it doesn’t work anymore. The web app (Easel) talks to a local NodeJS server (the Easel driver). For reasons unclear to me the web app tries to connect to this server at address http://inventableslocalhost.com:1338. I don’t see why this works for others, but it should clearly be http://localhost:1338 (one explanation I have is that for people where it still works the Javascript files are coming from the cache).

Anyway… a workaround is to make inventableslocalhost.com resolve to 127.0.0.1 by adding it to /etc/hosts (on Mac), something like this:
Heikos-MBP:~ heiko$ cat /etc/hosts
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost inventableslocalhost.com
255.255.255.255 broadcasthost
::1 localhost

2 Likes

Impossible to have the green carve button. I try all things. uninstall, restart computer, change USB port.
In the library/easel/iris.error.log - nothing the page is blank …

Do you have more information about this trouble ? thanks

So I just need to find this and do the workaround on my end (windows). The new problem I am running into is that after easel local starts installing, it gets stuck on “verifying install” and it does not install. Now one of my USB ports is not working. I left it on that screen all night thinking maybe my computer is just acting slow (7 y/o Asus laptop) and it was still there this morning. I rebooted and easel prompted me to download again. Didn’t have time to do it and headed to work.

@rodovich - is there anyway to run off the prior version until all of this can be straightened out? I deleted all of the prior versions, reboot, cleared cache, reboot, download new version, reboot, installed and got stuck. I have never ran into this issue before this update. I can attempt to run it the way @PhilJohnson recommended and might have to try as our business is at a standstill until this gets fixed.

Thank you all for any input.

that is what I am going to do. I will follow the tutorial you mentioned above when I get home tonight.

1 Like

Hi @Heiko, could you comment out the line you added to your hosts file and let me know what you get from running nslookup inventableslocalhost.com in the terminal? Thanks!

(The DNS is supposed to resolve to 127.0.0.1 and has been set that way for over a week, so it ought to have fully propagated by now…)

inventableslocalhost.com does not resolve for me

Must be something wrong with my DNS setup at home then, I’ll look into it when I’m home… (at work it does indeed resolve to 127.0.0.1)

The iris.error.log file was blank, now trying the 2.0.9 driver. The issue happend after these windows updates:

https://support.microsoft.com/en-us/kb/3135994
and
Windows Defender update- KB2267602(1.235.163.0)

Don’t know if these update have anthing to do with it…

[edit]
unfortunatly the 2.0.9 driver doesn’t resolve the issue

Hi Everyone,

We have pushed a change to Easel so that it will no longer try to use the inventableslocalhost.com domain name for now until we can do further investigation into why some DNS servers are not resolving that name.

If you have been having problems connecting to your Easel Driver because of this, this should resolve the issue.

We apologize for the problems this caused you.

Jeff

2 Likes

I just found my issue, I’m running DDWRT with DNSMasq to cache DNS lookups with the No DNS Rebind option set. This setting prevents inventablesocalhost.com from resolving to a private adress

Great, thanks!!

OK, this is what I had to do in order to get easel to work again. None of the above worked. I had to restore my computer to a point where I knew for sure Easel was working. Restore took about 45 minutes. When I restored, chrome did not work and Javaws.exe had opened about 4500 processes on my computer. Had to delete java (they recently had an update), delete chrome and reinstall chrome. Ran easel and accepted the download. This time the download actually worked and completed. Easel is now working again.

Every other time I attempted to run the new update to easel, it would always stick on “verifying installation” and would never complete the download.

I have no idea which was the issue (chrome, java, node.js or Easel local) but it is now fixed.

Same here
Everything was fine until update the driver

Nothing above works
Maybe we need a mac or windows 10?

1 Like

I’m on a mac, latest updates and easel keeps asking to install the driver over and over.

i’ve deleted easel, reinstalled, reinstalled an old version of easel, updated java, restated my computer multiple times, but it still asks for the reinstall.

the error log file is a blank file.

anyone get this fixed?