Easel Driver Update

I haven’t used for a couple of months and when I tried to connect to my Shapeoko II I got a message saying that the driver was out of date. As instructed by this message, I downloaded the new driver, but on launching the application nothing happened, and when I went back to Easel (even after restarting Windows) I got the same error message. How can I make this work?

Hi @GregMarshall,

We’re looking into a few reports we’ve had of the Easel Driver failing to run correctly after an upgrade, In some cases, installing 0.3.2 has helped. In other cases is has not, but it may be worth trying. We haven’t been able to reproduce the problem on our end yet, so we’re trying to gather as much information as we can to get to the root of the problem.

Also, can you check to see if you have log files in C:\EaselLocal\iris.error.log and C:\EaselLocal\iris.out.log? If you do, the information in those log files will be helpful for us in identifying the issue. If you’re not sure how to find those files, you can contact help@inventables.com, and they can walk you through the process.

Thanks, and we’re sorry for the problems you’re having.


Additionally, for anyone who is seeing these issues, if you have screenshots of the message Easel is giving you, that can be really helpful for us to diagnose the issue. There are a handle of different, but related messages that Easel may display, so a screenshot can help us determine the exact one.

Also, when you’re encountering these issues (or any issue with Easel at all), you can always submit at error report by going to Help -> Troubleshooting in Easel. That error report will gather a bunch of information that Easel does know about your system that can help us get to the root of the problem.


1 Like

Hi David,

Thanks for the suggestions. I did not find any log files. I would have tried removing the old driver, but you confused me by changing the name from “EaselLocal” to “Easel Driver”, which seems like a rather pointless change that only serves to confuse. That is, when I went to the Windows Control Panel to remove the driver I saw “EaselLocal”, but not “Easel Driver” and wasn’t sure that it was the same thing. Ultimately, I found that installing 0.3.2 fixed the problem.