Easel Driver Virus?

Just followed link to new Easel driver and my virus software blocked it as dangerous?

Same here. No option not to update and kapersky says it contains a virus. Frozen unable to carve by Easel again.

Seems a lot of the AV programs have gone nuts the past few days. Not surprising since a lot of them use the exact same common detection coding. Has given us a fit with our programs.:confounded:

1 Like

I submitted this to the authorities for review.

1 Like

Some software companies will recommend this because they know that their download files can cause a ‘False Positive’ detection for malware.

1 Like

Also a problem with Panda Cloud. Had to add it to the white list.

Thanks for all your comments.
I’m surprised it isn’t within the capability of the sw team to check and correct for this sort of thing.
Guess I’ll put off installing as long as possible, in the hope that any serious issues come to light.

Hi Everyone,

We are aware that more virus scanners are flagging the 0.3.9 version of the Easel Driver. Some also flagged the previous release as well. We are looking into why this is happening and what our options are for getting around it.

Rest assured that the driver is safe to install if you follow the link from Easel. You can tell your virus software that it’s OK until we find a more permanent solution.


1 Like

it doesnt work though…is anyone’s working

Installed and now I have no work surface grid, previous projects open but easel says there is nothing there and I can’t create anything as I have no idea where I am in relation to my work area.

1 Like

me too thanks for the post

Hi everyone,

We identified an issue in Easel that in some scenarios was causing problems like the one I’ve quoted below. It was not related in any way to the Easel driver. We have fixed the issue. We are sorry that you had these problems. The reliability of Easel is very important to us, and we work very hard to keep these types of issues to a minimum.


I’m am still experiencing the problem. Tried version 3.7 to see if anything would change, unfortunately it has not. I also tried signing in both through Google and Yahoo and Bing to see if that would make a difference.



me too…im sorry to even say something even after searching… cause people will bite your head off like you are stupid…lol well I checked everywhere and still wont work and its been working fine since april. I didn’t have the problem with any virus detection when installing.

I got mine about a month and half ago was working great till three days ago. Now nothing wants to work.

On a friends suggestion I downloaded and installed FIREFOX. My easel program is now working great! Happy that the people here share what’s going on so you know if your problem is unique.


Just to follow up: we have identified a second issue that is also causing the problem described in this thread where the workspace doesn’t load. This issue is limited to Internet Explorer users, and is not related to the Easel Driver. The Easel Driver is safe to install. We are investigating the issue with Internet Explorer and working on a fix. In the mean time, you should be able to work around this issue by using a different browser.

The 2nd issue has been fixed. Projects should now load normally in IE.

1 Like

Using windows 10, it keeps saying you are trying to give me a trojan… Cant receive the update in Firefox or IE.

Can I have the update without the virus, I mean I know the virus is free, but please? :slight_smile:

Hey Phil, I’ve been away from my table for a month or two and need to update my driver. My CPU is treating the file as if it is a Trojan. I’m searching the boards for a solution and this link that you posted is just cycling me on the same topic where there’s no solution. You got anything for this? I’m running W7 with defender.