Easel Hanging on "Choose a Bit" screen

When trying to carve, Easel lets me enter the bit diameter, but the button to allow me to move on to homing isn’t showing up. Interestingly, when I try to choose a bit by picture (1/8), it goes blue until I click elsewhere and then the “Other” bit picture goes blue instead.

Tried restarting Firefox, tried restarting the computer. I can only conclude that there’s been a programming change pushed through Easel since I last carved on Monday 12/21. Any ideas?

Project: http://easel.inventables.com/projects/Q7IeTSB_KQrLgfXGb5jOsg#

When I run a file that is large, it can take some tie to get past that. eventually it comes up.

It’s large enough that it slows my computer down, but it’s never taken more than a few seconds, maybe 30, to move past this screen. I’m now looking at 20+ minutes, which is highly irregular. Are you able to get past it with this project?

I get a script error in firefox on this computer and the laptop hooked to my xcarve is chugging away trying to open it still

i’d break that file into two parts

1 Like

Yes, it is hanging indefinitely at the choose bit screen.

In my experience with easel, I have found that tabs bring it to its knees. When you have a lot of parts, it kills performance. When I have a big file like that, I break it into smaller files. I’d make 3 files out of that project and try again.

edit: after letting it sit for a while, it crashed Chrome.

1 Like

I broke it into 2, and that worked. It’s not ideal, something must have been changed in the programming since the last time I did it, but at least there’s a workaround. Thanks @JDM!

I know Zach has said they are putting a lot of resources into improvements for Easel. I expect it will come around soon.

1 Like

It’s too bad my programming knowledge is so limited, I know he was looking for more programmers. I’d offer to work part time from home, but I doubt he would want to bring in someone who’s barely proficient in C and VHDL… :smile:

It’s beyond my skill as well.