Easel Ignoring my Plunge Rate Setting on initial setup

Hey Guys,

In easel I set my Plunge Rare to 80 mm/min & Depth Per Pass to 1.5 mm

When I do an Export to G-code (to inspect what is being sent to my CNC) I notice on the third line of code that the F or Speed is 228.6 and there is no way to change this in Easel?

G1 Z3.810 F228.6
G0 X79.577 Y22.299
G1 Z-1.500 F80.0

I am wondering if I set the Z Max rate on my GRLB Controller then this line of code will be throttled? i.e. only go 80mm/min max?

$112=80.000 Z Max rate, mm/min

Thanks Rob.

The third line is only a retraction, 3.810mm up (or any other value you might have set as safety height.)
I dont think you can change that within Easel, nor does it affect you 80mm/min plunge rate, which you see in the 5th line.

Thanks! I do understand that it retracts and doesn’t affect my plunge rate.
Its just that my equipment can’t handle a retraction that quick.

I could change the code manually and use a 3rd party gcode streamer or hope that it acknowledges my Z Max Rate!

Thanks Rob.

Ah, what is your equipment exactly?

GRBLs max rate will be the limit no matter what the Gcode says.

1 Like

Thanks so much its working as expected with the GRBL Settings changed!

I’ve got an MPCNC with T8 Z Axis, I believe it is messing steps because it is running to fast.

I had a ACME T8 Z aswell, it would plunge/retract fine at 3000mm/min (and 750mm/min*2 for acceleration)
This was with a Nema23 269oz/in @2,8A/24V

Wow that is hardcore!

my issue seems to be fixed by throttling the Z speed

Cheers Rob.

Are you running with a nema 17 ?