Easel in a death loop - won't start in browser

Hi, I haven’t used my X carve in a few weeks (life huh) - and now Easel fails to open in my browser window. I just get the scrolling 3 dots under PC icon.

Its worked for me previously. I’m running WinXP and have used it relatively painlessly on this rig. Anything changed that I should be aware of? Anything I should uninstall and reload.

I’m dead in the water here and a bit befuddled.

Thank in advance for any advice.

I actually had the latest Easel Local installed. But I uninstalled hoping to break the logjam. Oddly (sadly) - I am experiencing the same issue. It doesn’t even get to the point where the web page realizes that the local app isn’t loaded.

For anyone watching - here is how I fixed the problem. I’m not sure which specific step solved my issue.

  • I had already unloaded Easel Local
  • I logged out of Inventables.com
  • I cleared my browser cache
  • I cleared my browser history, stored data, etc.
    (I’m using Chrome, btw)
  • Downloaded and installed the latest version of Easel Local

Next time I loaded Easel, Iogged in Invetables.com and it went right to my project page.

So - that problem is solved… for now…

1 Like

I’m having the same problem. Easel wont load/open, just the icon and 3 moving dots. I tried everything listed above by MichaelTrader except deleting Easel local. Maybe this is a silly question, but if easel wont open how do I download a new copy of Easel ? Easel and the X-Carve were working fine on Monday. I’m running Windows 10 using Edge for browser.

Ok the old brain is starting to work. If slowly.
Easel local is in the build instructions. deleted the old and installed the new. No change Easel still wont open.
What next?

Edit Just tried to open Easel on the other computer in the house. No joy there either. Must be an Easel thing rather than a computer thing. I’ll try again later.

I’m also having this issue! There are a handful of JS errors in the console, so it seems like they may have pushed an update live that isn’t fully compatible. Hopefully they fix it before heading home for the weekend!

Called in to support, they are aware of the issue and the developers are working on getting it fixed.

Just started for me today, but only on my windows 8 machine, win 7 is working fine

looks like Easel is back up and running