Easel is Crashing Safari

I’ve read a few of the threads researching this problem and found nothing to solve my problem.

The X-carve is brand new and haven’t been able to use it yet. I’m using an Macbook Pro, OS X 10.7.5, 4 GB RAM , Safari (v6.1.6). I plug the X-carve into the computer, turn it on then launch Easel. The easel screen comes up then the password is accepted and starts to go to my screen, stalls and crashes Safari. I’ve tried going in reverse of that and it asks to plug in the X-Carve when it already is.

Any suggestions?

Have you tried Chrome?

I have a Macbook pro running OS X Yosemite 10.10.4 (I think its a free download) and Safari 8.0.7 and Easel connected first time. I suggest getting the latest version of Safari and seeing if that helps.

I’m with @RobertMatusiewicz on this one… if you can, upgrade your OS and Safari if you can. But if you can’t, then the latest version of Chrome is probably your next best optional as @NAM37 says.

Sorry for the delaying responding. Thank you both for your input and help. I found that my Macbook pro is a 2006 and not a 2007, so I can no longer upgrade OS or Safari. So, I’m hoping that my PC on windows 7 can do the trick. Thank you @RobertMatusiewicz and @sketch42.

@KeithBranch can you install the latest version of Chrome and try it?