Easel is not connecting to X-Controller on macOS Sierra

Hi community,

I got my X-Carve this week and finished the assembling.
Now I tried to setup my machine through the Easel setup but it gets no connection to the X-Controller.

I am using 15" MacbookPro Mid2015 with a 2.2Ghz i7

I followed the instructions till I got stuck.
These are the steps I made and I just don’t know what am I doing wrong?! :confused:

  • X-Controller is connected right inside (double checked)
  • X-Controller is powered and turned on (steppers are not moveable / fan is spinning)
  • I installed ‘EaselDriver-0.3.2.pkg’ and in the Machine Inspector in Easel it says that exact this Version is running. (I also tried 0.3.1 and 0.2.9)
  • When connecting the USB-cable an FTDI-device is showing up in the system information in macOS but no reaction in Easel Setup.
  • tried Chrome and Safari
  • restarted the whole system
  • no other programs are running

Does anyone has a hint what might be wrong?
Do I need another driver?
Do I have to enable / disable something in the browser?

Here is a picture from the system information with the new device:

All other topics I found here are all related to the older Arduino-board version and didn’t help me.

Greetings from Germany,


good news, I finally got my X-Carve working with Easel.

After digging around the internet for COM-Port issues with macOS I found some interesting posts over at the Arduino forum where Arduinos were not recognized in the IDE.

Solution for me was to install the FTDI-Driver from the official FTDI website

After a restart the Device showed up in the Terminal using ls /dev/tty.*

Then Easel was able to see the X-Controller.


What was the tty name? Just not sure what I’m looking for there… it’s annoying because I’m in the middle of configuration, had to pause to switch a wire and now it’s not connecting… so it was communicating and now it’s not.

I am not sure, but I can check tonight when I am at the Makerspace.

I had one entry, when not connected:

And when I connected the USB a second device appeared.

When connecting the X-Controller appears as /dev/tty.usbserial-A700OOBW

1 Like

I’m starting to narrow it down, but right now I think it’s in the helper. When I start working with the x-carve, things are good, but if my mac laptop goes to sleep, the helper stops showing up in /dev/tty and there is no communication with the x-controller.

Also, if I disconnect the USB cable do something else with my machine, then try to reconnect, it fails to see the x-controller.

So far, the only solution that I have working is to reboot my laptop… ugh.

Is there a way to poke at the helper running on my machine and make it re-start or reconnect? I feel like it’s a black box and I’ve lost contact with the process inside.

Just to be clear, I understand how to prevent my laptop from sleeping (I’ve been writing software for 35 years). The issue is that I fundamentally cannot connect TWICE to the x-controller. I used the “sleep” session as an example of a situation where the connection to the x-controller seems to go stale.

Yeah, missed that I had to restart, too :blush:

For now its ok, I am able to test carve.
But a solution without restart would be great. :slight_smile:

1 Like

We are a primarily Mac-centric school, so we’ve had a chance to try this on multiple machines now with the same result. Is there a way to identify the driver process and kill and then restart it? Is it possible it’s not compatible with my Arduino-related FTDI drivers?

I wrote directly to Inventables support yesterday if they have a hint/solution/workaround without the need to restart.

I am curious if we get it working soon. :smiley:

I just managed to solve my problem. :grinning:

So I want to share my solution:
After a bit of research yesterday I found out, that since the last MacOS Update to Sierra Apple added their own FTDI driver to the System.

So the solution was, to remove the other two FTDI-Drivers I had installed from the kernel extensions.
And now it connects / disconnects without a single problem and without a restart :+1:

I am pretty happy

Here are the links that lead me to the solution:




This problem had me stuck for a while. I am glad MichaelCastano had post the solution.

THE PROBLEM - Back story and details of my OS. You can skip ahead if needed.
I upgraded my computer’s os to High Sierra from El Capitan
After plugging in the USB, Easel would not recognize the X Controller. Though the “CARVE” button was green. It would lag as well.
When I opened up Advance in the Machine Tab in Easel, the code read out a bunch of error: 9. Looked something like this.

error: 9
error: 9
error: 9
error: 9

If that is what you are getting after installing the upgraded os, this may be your problem.

The problem is with the drivers competing with each other to send signals at the same time, which is what I understood from digging around on the net.

The solution was a bit tricky to follow. so I will tell you how I did it in as much detail as I can incase you run into the problem yourself. This is my route that worked for me and if it works for you then awesome.


First off, Thanks to MichaelCastano, the link that was posted was helpful. I have copied and pasted the sections that worked for me.

Step 1.

  1. Download the 2.4.2 drivers from FTDI’s website http://www.ftdichip.com/Drivers/VCP.htm and install. The install will succeed, BUT due to Apples built-in FTDI drivers they will not work.

  2. Reboot computer and enter recovery mode Via powering down and holding down CMD + R on reboot.

  3. In recovery mode open terminal from ->utilities<- at the top of the screen. Then type the following below to temporaily disable System Integrity Protection:

csrutil disable

Note: This will disable the lock that allows you to throw away important .kext, which are used to run the Mac OS efficiently. Other than what you are changing, you wouldn’t normally need to go there.


After you have restarted, the extension you are trying to find is AppleUSBFTDI.kext

How do you find it?
“your harddisk”—> System ---->Library---->Extensions

In the Extensions folder, you will see a bunch of them. Scroll down until you see AppleUSBFTDI.kext "Mine isn’t there anymore because I have deleted it.

Step 3
Use your best judgement on this, I am not a guru. What I did was right clicked and deleted it from the extensions folder.

Now, if you have followed STEP 1, you should have 2.4.2 drivers from FTDI already installed on your computer.

If so, you can do a test. get easel up a running with a test project on your browser. Then if the carve button is green click on it. It will run you through the steps before carving.
When you get to “SECURE MATERIAL” step, move the X Carve around to make sure your stepper motors are registering. If that works, then you are done with the hard part.

NOTE: if you change to enable, “csrutil disable”. Then it will stop working. That is what i found out.

This is what worked for me. Thanks to all the people who have provided some information. I hope that was clear enough and that it will save you some time digging around.

If there is something better, please let me know and I will try it for future reference.