Easel keeps changing my cut setting - metric/imperial conversions?

I’ve got a project that I’ve been carving for the last couple of weeks and I’ve got a problem with Easel. When I open up the project my depth settings are screwed up! I’m using metrical units and for example set my text to be cut at 2.7 mm, my I open it up it has changed to “2.7176”.

I’ve have to go through my entire project everytime to correct these faults. Is it a conversion error? Are the values stored in imperial units and converted back and fourth?

At the bottom near the zoom buttons, change the inch setting to mm.

I mean this: https://www.dropbox.com/s/uaxzuf9gzrvcba6/Skärmklipp%202015-07-23%2015.04.29.png?dl=0

That depth value used be “2.7”. But it keeps changing everytime I open the project.

If I set it to “3.1” and open it up again it has changed to “3.1294”.

Is this a known bug?

Currently there’s a limit to the resolution of the values that Easel stores between sessions. They’re stored as a fraction of the material thickness, not imperial units, but you’re correct that it’s a conversion error.

Depending on the size of the error, it might not actually affect how your project turns out—that 0.02mm might be close to the tolerance of your machine—but it’s annoying either way.

We’ve been working on some changes to the way that Easel stores shape positions, sizes, and depths, which should solve the problem. There’s a lot going on under the hood for this, but we hope to have these changes live within the next week.

That sounds great! It sure is a small error, nothing that matters for my project really, but am I wrong that it might make some extra (unnecessary) passes if I’ve set my depth/pass to an even multiplier of the cut depth?

Say I want to cut 3mm and have 1mm/pass and the depth is changed to 3.012… Will that make for four passes instead of three?

My bad. It was late last night and I wasn’t reading the numbers you posted properly.

I have had the same problem. I might place a specific value for a shape and it will be just slightly off.

Most common is when I move and object’s lower left corner to x=0 y=0. When I come back to it, the position is x=-0.2 y=-0.2

I just change it twice and then check it a third time to make sure it didn’t change… same with depth, but as @rodovich said, that might be fixed soon.

They’re stored as a fraction of the material thickness, not imperial units, but you’re correct that it’s a conversion error.

Does that mean that changing the material thickness changes the depth of cut? For example if the material is 1/4" and the cut is 1/8", then the cut is 1/2 the thickness of the material. If the same design is then used on 3/4" material, would the depth of cut become 3/8"?

Yup.

Yes, currently that’s what would happen. Our thinking initially was that this would help in scenarios where you start your design before thinking about the material you’ll use, or where you design for the material’s nominal size and then measure a slightly different thickness when you’re about to carve. However, based on the feedback we’ve gotten, people typically aren’t expecting the cut depths to change like that, so in the future we’ll most likely only adjust cuts that are set to go all the way through the material.

Another thing that changes from inches to mm…sometimes if I’m in something like the bit size (either in the machine setup, or when confirming the bit size during carve)…if you hit tab to tab out of that box, sometimes it uses that tab move to change from in to mm…not sure it happens all the time, but it’s happened to me.

Tried to use a 3/4" straight to clean out the waste board…wondered why it was moving in such tiny increments…stopped it only to find it was in .75mm mode

Thank you rodovich, I now understand the problem I was whining about last night. Presumably, I can maintain the “proper” cutting depth by lying to the program. I’ll just tell it that I am using the original thickness material unless I actually want to make a through cut.

I do understand your thinking in storing the depth of cut relative to material thickness however, and now that I understand, and also understand a way to work around it, I can see the utility.

If there was a way to choose between “maintain original depth of cut”, and “scale depth of cut proportional to material thickness”, that might be good. (Says the guy who didn’t even know what “CNC” stood for 3 weeks ago)

Hi everyone,

This has been fixed. Cut depths are now saved as actual distance values with much more precision, you shouldn’t find them changing anymore when you reload projects.

4 Likes

Thank you for the quick fix. There does however seem to be a new bug introduced.

Scenario: I copied (Ctrl-C) a project into a new project. I then tried to change the material thickness to the same as the previous one (12mm). But Easel says that is not allowed since some cuts are deeper than “0.4xxx inches”. I’ve checked and the deepest cuts are 12mm (as in the copied project), so this should be fine!

If I first change the thickness of the material and THEN paste my vectors then it works.