Easel keeps going white...then black

Hi, I’m new to Easel. I’m actually in the 30 day trial period and considering purchasing a subscription to it for the Maslow CNC I am building. Loved it at first but over the last couple days I have had it lock up- crash- whatever you want to call it
Sometimes on login my browser will turn white with dithered rectangles where the toolbars were. If I wait long enough it turns black. I discovered that when it is white on login that I can hit the refresh on the toolbar and the login will come up. I have gotten in doing this but then when I clicked on “learn” it crashed. This has also happened in the middle of a session as I’m uploading a file, setting cutting parameters, you name it. I can’t figure out a common denominator for what causes this. I’ve had this happen using Firefox and Chrome browsers. The last time it happened, I did a restart on my computer and when I opened the Firefox browser, it was still black. It seems to open in Chrome when Firefox goes black but something is wrong.

Any ideas? I was so excited about Easel a couple days ago I was ready to purchase an Xcarve to have alongside my Maslow. I’m hoping it is something simple.
Thanks, Jerry

I haven’t ever seen a post about this issue… I would guess it has to do specifically with your pc, possibly the graphics card limitations, but honestly, easel doesn’t require a very good graphics card to begin with… ist run just fine on some pretty old and cheap laptops perfectly fine for me, but I haven’t tried windows 95 :laughing:

What model computer and operating system are you using?

Its a Dell laptop running windows 10 with 1TB of memory. Never had a problem running anything graphics wise. I actually was using easel for a couple days with no problem. I was thinking maybe there was a common problem but it must be something I did. It all started when I was deleting a bunch of practice projects that I was learning with.
Thanks for the response

1 Like

By chance, have you tried restoring your browser or Windows to a recent version prior to when the issue first started?


Brandon Parker

1 Like

Thats a great idea. yeah I just had a hard drive failure and swapped it out with a solid state hard drive. I had just got the easel trial an hour before the hard drive failed so the couple days of successful use of easel was actually with the new drive. But that said, I will try what you said.

I have been experiencing the same issue within the last week. no issues with my MacBook, everything is up to date. I will be working in easel, it will freeze, everything disappears, then a few moments later it will pop up again. but when I try to continue my work, a message pops up and says this project has been modified and needs to be copied in order to continue.

try rebooting your browser and clean up your cache files.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.