Easel local wants to be installed over and over

I have the x-carve working with my good laptop, but on my older Laptop in the shed easellocal isn’t running in the taskmanager. I use on both Laptops Windows 10 pro, arduino 1.6.9 (but i tried 1.8.2) drivers, easel local 0.2.2, 0.3.2, 0.3.3, CDM21224, Chrome (webgl is enabeld), under the com ports in the device manager I can see that it detected the board but i can’t get the Arduino name to show up (on both Laptops)
So I can carve on on one laptop. On the other one easel always tells me to install Easel local.
Maybe you guys have an idea what i can try.

Thanks and greetings from germany

I tried it again with 0.3.2 but it is still not working

Can you break your sentence into segments so that we can clearly see what you have on each.


laptop 1
new with windows 10 pro - chrome browser - easel local 0.3.3

laptop 2
older with windows ? - firefox browser - easel local 0.3.2

etc. etc. your original post is somewhat confusing about what is what.

Above I listed everything I tried on the old one

Latop 1 (working and new)
Arduino 1.6.9
Easellocal 0.3.3
Windows 10 pro

Laptop 2 (older setup up at the moment)
Fresh setup of Windows 10 pro
Arduino 1.6.9
Easellocal 0.3.2
Cdm 21224

I would try to uninstall the Cdm 21224 driver and only install the easel local on the old system to see if there is a conflict between the Cdm driver and the easel local driver.

I uninstalled the driver and reinstalled easel local but it didn’t change anything :frowning:

Having the same issue - was there ever a resolution on this?

Difference is that everything was working fine - i took a week off and then when i tried to log in easel kept sending me to download and install the driver over and over. I tried twice. I dumped my cache. I rebooted. I’m running Windows 10 and have been ever since my first connection to my xcarve. No new hardware added to the machine.

Having same issue. Windows 10, X-Controller. LAst week Easel worked fine. Tried to start working on projects again this weekend and all EAsel wants me to do is install Easel wants me to do is the following over and over and over. I have removed and re-installed, downloaded most recent version. Nothing. I verified EaselLocal is running in services. Last Windows updated applied were in mid-June.

Any Ideas?

My X-Carve is an X!#$##@$%@%-Carve right now. :slight_smile:


Whitelisted Inventables.com domain in ADBlock software and Easel works now
Thanks @JoshuaDunn! Saw your suggestion in this thread Easel 0.3.7 don't work for me


1 Like

thank you @AWebb !
that did the trick