Easel No Longer Loads on Firefox / Linux / Chromebook

We’ve been using Easel Pro on our Chromebook with Linux using Firefox for ages. It recently stopped working and I can’t figure out why. The login page no longer loads - it just shows a blank white screen. I’ve tried going to inventables.com and clicking login, and I’ve tried just going to easel.inventables.com but either way I get the same result. The rest of the website (inventables.com) works fine, and other websites work without any issues, but every time I try to get easel up and running, it’s blank. Anyone out there that might be able to help out? Thanks so much!

1 Like

Seabright,

Did you try clearing your history and cache and then restart your pc

1 Like

I also run linux for my shop xcarve laptop, and i know a new driver recently came out for the xcarve on linux, not sure if thats the issue but you could try updating the driver

Yes I’ve tried clearing history and cache, I’ve also uninstalled Firefox and all Mozilla/Firefox folders then reinstalled but still no luck.

I just tried that but it says that the driver is the same as the version I have installed. Still not working. :frowning: