Easel not detecting my Shapeko 2

Well I’ve tried everything I can think of, but l easel is not longer detecting my Shapeko 2 (Pre X-carve machine sold through Inventables)

My OS is : Mac 10.14.6
I have tried both Safari and Chrome
I have updated the Easel Driver
-Then after not connecting
I updated Arduino 1.8.12 (It does detect my Arduino Uno through the USB)
I updated the GRBL in Arduino to 1.1
I turned off the Firewall
I have no antivirus running
I tried different network configurations
I tried different USB ports (Arduino does detect my Arduino Uno)

What else can I try??

Make sure the Arduino serial monitor is not open.
A different sender. I prefer CNCjs for most things.

1 Like

Progress! CNCjs can connect to my Shapeko2 and I can move the spindle on all axises, so I will begin learning the interface and try and carve. But I am still wondering why Easel can not detect my machine (carve button not turning green) while I am sure CNCjs has a bunch more control and options, I do like the super simple Easel interface.

Thank you NeilFerreri1 for the suggestion!

Any other thoughts now that I know my board is not fried and my GRBL code is working?

PROBLEM SOLVED: I fixed the issue of not being able to connect to Easel by manually removing the driver files and then reinstalling them. Here is the link to how (on a mac)

1 Like