Easel not doing finishing 3D carve

So I just got around to do my first 3D carve. Got everything set up and completed the roughing perfectly. When doing the finishing carve, nothing happens. I go though the probing process, hit the carve button and nothing happens. At first I thought it was just taking a long time to generate the required toolpath but it continues for a while then the machine just stop. This one boggles the mind. HELP…PLEASE…

1 Like

It’s pretty tough to troubleshoot this issue without seeing the project firsthand…
Can you share the Easel Project? IF it’s a copyrighted design than you might not want to post it here and you can PM me the link instead.

To Share the project go to Project>Share
then set it to “unlisted”
then copy the link
and then paste that link here or in a DM

thanks!

Thanks for the follow-up. Appreciate it. Here is the link;

1 Like

Hmm it loads up fine for me. One thing you could do is save the Gcode and then import it back in, then you wouldn’t have the router running while it calculates the toolpath all over again just prior to the carve…
I think this might alleviate your current issue.

Thanks for the tip. Will try and see how that work. Know this will be a great piece when completed.

1 Like

Just a heads up. I tried your suggestion and still did not work so i looked back at the laptop I use with the machine and discovered that it actually ran out of RAM memory when easel is generating the toolpath for the detail cut. Never thought about that because I never had to cut a file this big. Will either use my desk top or get additional memory for my laptop.

1 Like

Oh yes, that could explain why it worked fine for me. I use a fairly loaded gaming laptop with 65gb or RAM and a top of the line (2 years ago) processor. So I could see how it might not run into a RAM cap with my setup… I’ve also seen people recently talk about clearing the browser cache having a positive impact on the toolpath actually calculating when it previously would fail, just another thing to look into if the PC won’t do the job…

This is an issue I ran into a little while back as well - to the point that Easel Pro would generate tool paths but would not execute the detailed carve. It would sit there with the spindle stationery and then the carve dialog would just disappear 15 minutes later.

I raised this with Easel Support and they referred it back to their developers (no resolution yet). For large detailed carves, the only reliable paths seem to be g-code generated.

If you are persevering with Easel for this, try it on Firefox - Firefox seems to have more adjustability on browser parameters, including network timeout etc.

1 Like

I spoke with my son who does programming on his job and he was amazed that this even happened. This should have been addressed before releasing the new updates to Easel. Not sure what easel developers are doing but hope they are addressing this issue, especially if it happens to end users who cant afford an expensive computer.

1 Like

The sad way of the world these days is that the customers end up doing debugging - it’s not just Easel, but Microsoft, Adobe, Apple, Samsung… everyone! But competitive demand drives this.

As they say, you can have it quick, or good, or cheap but not all three

2 Likes