Easel not recognizing my cnc machine

It seems my problem persist from 2016 and still easel could not resolve this.
After entering my machines details and clicking confirm settings, I do get the following prompt Plug in your USB cable and turn on the machine. The usb is plugged in and the machine is on. And in device manager the port is shown. I do not get the prompt to enter the port manually. I have reloaded easel and arduino 3 times already. The version I am using is 0.3.16 the only one available on easel inventables downloads.

Hi Daniel - if you’re still having issues, please reach out to our Customer Success team (help@inventables.com or 312-775-7009)

Hi My cnc masjine is a Cron Craft fitted with a Arduino board.

Still no progress. Following the instructions on https://inventables.zendesk.com/hc/en-us/articles/360012725634-How-do-I-re-flash-Grbl-to-my-X-Controller-Arduino-. problem start hear == To add the Grbl library to your Arduino IDE, open up the IDE and navigate to Sketch - Include Library - Add .ZIP Library…== Click into the un-zipped grbl-master folder and choose the grbl folder.

It gives the following error:
Arduino: 1.8.10 (Windows 8.1), Board: “Arduino/Genuino Uno”
Specified folder/zip file does not contain a valid library
Specified folder/zip file does not contain a valid library
Specified folder/zip file does not contain a valid library
Specified folder/zip file does not contain a valid library

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

Some more info. It seems eseal does not save the machines details. And downloading GRBL from the link you provided it continues to download for more than an hour and never stops.

The GRBL the file that’s been downloaded is 293 kb big.

If you can lock in remotely I also think is the best solution.

If you don’t have grbl installed, Easel won’t be able to connect.

It seems like that is where you are stuck. What file are you downloading?