Easel not returning to start position

I generate the gcode in vcarve, import it into easel confirm home position and begin the carve… The part turns out perfect in the exact position on the work piece it should be. When it finishes carving, it makes it back to the correct X position but the Y pos. only makes it back 1/2 the distance to the home? One thing I noticed is the return speed is balls to the wall WARP 10!!! Iam thinking The Y can’t get going that fast and the steppers won’t move, besides it cant be good for it. Chillipepper never returned home that fast and it never had a homing problem either…

Is there a place to change the go home speed?

I had to man sorry lol

But no seriously I am not sure how to change the rapid movement speed with your current setup hopefully someone will let us both know

probably a setting in the post processor though

This might help, the $numbers may vary between the GRBL versions but the wording is similar.
You may want to tweak these.

Love it… We have cats and know there is a nap to follow


I use Mach 2/3 archs atc in v-carve

I did some more research and solved the problem.

I found this old thread

Basicly said:
If you go to Easel’s Machine Inspector, you can adjust the following settings that relate to speeds:

$24 Homing feed
$25 Homing seek
$110 X max rate
$111 Y max rate
$112 Z max rate
$120 X accel
$121 Y accel
$122 Z accel

To change a setting:

  1. Go to Console and type in the change you want (i.e. $110=8000), and press enter
  2. Refresh the settings by pressing the double arrow icon above the settings box
  3. Reload Easel

So I changed
$110 X max rate from 8000 to 4000
$111 Y max rate from 8000 to 4000

And it works perfect

My steppers were basically stuttering from over current. I could have also just increased the stepper driver current or slowed down the accel rate but since this worked I will leave it.

Thanks again for your suggestions.

1 Like


I’m glad you found a solution to your problem, but the change that you made is covering up a problem somewhere else. (assuming you are using either the Arduino/gShield or X-controller).

8000 mm/min for $110 and $111 is entirely reasonable and not overly fast on an X-carve that is functioning properly.

Yes I know it was an “Under Fire Field Fix” but I just wanted to make more parts cuz Christmas is coming sooooon :slight_smile:

1 Like

probably should of left it at warp 10 then lol

What controller you got?

Long term solution may be to recalibrate the current limit pots. May not be over-current, probably under-current situation?