Easel not working in windows 10?

Just got a laptop set up to use with the X-Carve, and wanted to do some tests.

I uploaded a simple Gcode file, and hit Carve. A window pops up telling me it cannot find my machine, and I cannot go any further.

I have verified the device shows up in device manager, and can communicate with it using terminal software in the same computer.

I went back and connected to my other computer to see if it worked there, and got the same prompt, but was allowed to manually enter the com port to proceed. Everything worked fine.

Is there something I am missing?

Had a problem with connecting to my X-Controller through Easel for the first time last night. Think another instance of Easel or other application may have been conflicting. Some combination of restarting Chrome, powering up and down the X-Controller and waiting about 10 seconds for Windows 10 to recognize the device fixed the problem. When Easel finally sees the device the Carve tab should be Green not light Blue.

Thanks @rpegg. I’ve tried restarting windows, chrome, disabling the firewall, reloading easel, and everything else I can think of. As I type this my computer has sat idle for about 10 minutes to see if it would eventually register a com port. I’m at a loss.

UGS seems to start up and run fine, so I can use that for the time being. I would really like to get Easel running though.

1 Like

You have installed Easel local, right?

Yeah. I verified in Task Manager that the service is running. I just can’t communicate with the board

Got it working. I had to look in the downloads and downgrade to version 0.2.2 of the Easel Local software so I could manually enter a com port. The auto detection was not working.

Found the solution here:

Thanks @rpegg

1 Like

@BradT Sorry to hear about the issues. Do you know what version of the Easel Driver was giving you issues? 0.2.2 is quite an old version (released in late Octotober/early November) and we may drop support for it at some point.

If you don’t mind installing 0.2.5 which you can find on the downloads page and seeing if it works? If not can you please click the “Submit diagnostic info” in the modal that pops up when you click the blue “Carve” button?

This is a recent feature that is best supported by Easel Driver 0.2.5 (which is why I’m recommending you upgrade before submitting). Please leave a reply here or message me when you’ve submitted it.


Thanks for the reply @EricDobroveanu

I tried 0.2.5 before downgrading. Initially it installed 0.2.3 when I first ran it on that computer. I then uninstalled and went to 0.2.5. I never tried 0.2.4 before going to 0.2.2.

Just to double check, I uninstalled what was working and reinstalled the latest drivers. It does not detect the board.

I am using latest updated version of Windows 10 on an Acer Aspire laptop with the newest version of Chrome (downloaded yesterday onto a clean windows install).

I just took a few minutes while typing this to try something. The Arduino I am using is a clone board with the CH340 USB to serial chip that is typical in many clones. That driver is not being recognized by Easel. I flashed GRBL onto another uno with the standard USB chip (and USB B connector), 0.2.5 seems to recognize it straight away without issue. I prefer using the CH340 board due to the convenience of using the usb micro connection, but I can use this one if I must. I’m just not sure it still works.

1 Like

Thanks for the detailed reply @BradT, I’ve added it to our internal bug tracker for further investigation.

I hate to bring up an old bug, but this still is a problem for me with my windows 10. I cant download the version that’s talked about here to try to see if this fixes my issue. My grbl is updated to 1.0c that was forked for the xcarve. Chilipeppr and the json serial port work fine on win 10, but easel does this exact same thing as talked about here.

Com port is set correctly and I know the com port number. Cant do a machine setup, it does not see the machine, just sits there looking for it. Never times out and there is no place to manually put in the com port on any version that is avail for download on the site.

The cable it fine, it works 100% on my windows 7 laptop. Just not on win 10.

I never seen that on the latest version, but i suppose i could have missed it. I will recheck again to see if i can find that option.


Phil, you nailed it. after i manually entered the com port everything worked. So i think there is still some work to be done on the automatic comport detection with windows 10. Anyone else having this problem, try Phil’s suggestion.

1 Like

I installed the easel program but icon or program is not there.
why? i ran as admin but after install it just isn’t there

Just purchased an HP Windows 10 laptop for my xcarve. I started with a Mac but got a windows pc for when I eventually purchase vcarve but it’s not recognizing the controller. I’ve read through all of the older posts but curious if the latest driver installed could be causing the problem.

Hi Bill,

The latest driver works with Windows 10. Have you followed the steps listed in our support center?


I got it working, had to download ftdi drivers.

1 Like

Great discussion about easel working issues in Windows 10, actually it’s not big issues you can take the help with technical expert. They are fix problems online, if any problem to contact them just get help from https://www.printererrorsupport.com/blog/brother-printer-offline-windows-10/

Hey Gang! When I turn on the motor when using easel it kicks me out? I have to unplug from the port and re plug into another port, restart the program and then I can get it to reconnect. But when I start a new project everything works fine until I turn the motor on. If I run without turning the motor on it will run? I have uninstalled - reinstalled and checked every connection? Anyone have any ideas please?

1 Like