Easel on Mac stopped connecting to X-Carve, UGS still works

I’ve been using Fusion 360 and UGS, which has been working fine. Today I just needed to cut a quick circle, so thought I’d use Easel. It prompted me to update a driver, which seemed normal, as I don’t think I’ve used Easel for about a year. I then rebooted, and tried to connect with Chrome as usual, and no go. I also tried Safari, tried different USB ports, re-booted again.

Searching the forums, this seems to have been an intermittent problem, but with no consistent answer. I’m on my old Macbook Pro, I think it’s a 2009 model, running OSX 10.11.6 and I have one of the early 1000x1000 X-Carves that has the Arduino G-shield.

Do you have Formates your Hard Drive case sensitiv ?
This helped for me

Thanks. I just tried switching the “I” in “Iris” to lowercase based on that thread you linked, but it still doesn’t connect.

yes, i do

try make a symbolic link so you have both

Post your serial number. 10.11 is kind of old to be running Easel properly. It won’t support the latest version of Safari (or any browser) which should be Version 11.0.2 (13604. Updates for browser and Mac firmware might not appear, because you get them as part of macOS update, which in your case is outdated.

Have you ever updated any hardware on the Mac?