Easel on Mint - Not connecting to Arduino

I have spent a bit of time attempting to resolve the problem but going nowhere. Before continuing, am I attempting something that is not possible? I have Linux Mint 20 and the easel driver working in that I can load, modify projects but just cant connect to router.
I attempted to run on a USB copy of Ubunta but that failed I assume as not “installed” I have no problem changing to Ubunta if this will solve the installation.
All help appreciated.

You can actually do easel off the USB preview version of Ubuntu but your install of the easel get wiped since the OS is read-only), but it works’ish. I did find some permissions issues with the port at one point with running a non-priv account (my user does have sudo privs but I run in regular user account mode for safety - although I don’t care what happens to this dedicated linux box on my x-carve it is connected to my network of course, and that I do care about)

I thank you for your assistance. I installed Ubuntu on a separate partition. I assume the driver is operational in that I can log into my Easel account. When I try to set up my machine I get “Install Easel driver” which I have done several times. This is followed on with "failed to install file: not supported"I
I appear to be doing something wrong?

I think in the “Try Ubuntu” mode it is essentially read-only, and it is likely preventing the driver from working.

Thanks Henry for info. I kind of gave up on Ubuntu as I was bumbling about not really making progress. I must be doing something basically wrong being unable to communicate with neither systems. I can persevere but just need clarity as to what I want to do is achievable. At the moment I have a number of options to operate my router from project I have created in Easel. I can use the Easel G-code in UGCS installed on the same machine or send to my MacBook Air and use Easel on that machine.
Really finding it frustrating that I cannot achieve what I am sure others have.

Just an update although no further forward. In Ubuntu I have now managed to install the driver but still not connecting???

Sorry you are having all these problems. One problem I weirdly found was my user couldn’t access the USB port in question. Are you connecting in easel (i.e. it’s blue and you can’t make it “green”?) I had a bit of this at the beginning. Make sure you are fully updated in Ubuntu (and I assume at this point you are running full ubuntu not the USB-try it mode?). at the suggestion of some others I switched yesterday to cncjs (not to add a whole other problem to your life) on ubuntu. It’s like UGS but without the clunky Java application feel. But one problem I often see (on 3D printers in Octoprint or UGS or any unix based computer) is figuring out which USB port is active (I like that cncjs calls the USB ports by the manufacturer at the far end - e.g. the port with the x-carve shows up as “inventables” but this may instruction might help make sure you are on the right port):


I assume you are running on an x86 PC of some kind (not attempting this on a Raspberry Pi?) Because the Inventables driver is x86 only (wasted an afternoon before I saw that). Now there is an open-source easel driver for the Rpi (just search the forum and you’ll find it, it is maintained by one of the forum users: @SamyKamkar )

1 Like

Thanks Henry,
Yes I can open Easel but cannot turn the blue to green. I found that I had not the driver installed in Ubuntu but have subsequently achieved but still not connecting. This is on a fully installed Ubuntu on a separate partition not USB mode.
Using lsusb I can identify which port the Arduino is connecting to but in the dark as to how to get Easel on to that port???
I am using a HP-500B-MT-Desktop-Intel-Dual-Core-E5800-3-20GHz-4GB-RAM-160GB-SSD
I found the Samy Kamkar driver today and have tried that to no avail. Although I thought I loaded it I am not sure if it has managed to overwrite previous and will need to find a way to remove the Inventables driver to test??
I appreciate your assistance and am sure I will eventually prevail.

I got there at least on Ubuntu and will now try on Mint. I deleted all drivers and then installed Samy Kamkar driver and all appears ok.
Thanks again for your help

1 Like

yeah, that can be an issue as only one thing can use the port at the same time as far as I know (at least for serial connections)

I have nearly got where I want to be in that I prefer Mint and am now able to do so. Only problem is that I need to load the driver on a reboot although something like crontab was modified to do this on start up. Not to concerned as just a fiddle. I did glance through Samy Kamkar’s notes and I do not think the Inventable driver works on the AMD chip I have in my machine. Anyway, onward and upwards.

You are all talking way over my head on most of this, but I had a connection problem two days ago and was pulling my hair out (I’m not very computer savvy). I was about to order a new control board, but before doing that, I tried a different usb cord and that fixed my intermittent connection problem.