Easel only find X-Carve once, then have to restart

I am on OSX 10.12.3 using Safari or Chrome.

Everytime I want to use the X-Carve I have to restart my computer before it is found.

If I have to unplug the USB, or shut off the X-Carve for any reason, I have to restart my computer again to re-connect.

Switching USB ports does not improve the results.

This is very annoying. Any pointers?

I’m using a Mac Mini 10.12.3 as well without issues. Are you connecting to the XController? Did you load the latest driver? v3.3?

It does connect and work fine, it just doesn’t if I try using it a second time without restarting.

Are you saying I should or should not delete my cookies? (I have not)

Should or should not clear history? (I have not, auto or otherwise)

Yes, I am using the XController. I followed the setup instructions and do not recall a driver step or download for Mac. Where is the download?

I installed 3.2 and it helped, however if it is not wanting to connect just installing it again will make it recognizable.

Confused. Think I’m missing something.

Isn’t Easel a web app? How do I (un)install it? Where do I get various versions?

Here’s where you get the drivers: http://easel.inventables.com/downloads

1 Like

The recommended troubleshooting steps in this circumstance (can connect once, but not again on OSX), are to first check if the FTDI driver is installed by following these steps:

Open Applications → Utilities → Terminal and run the following command:

kextstat | grep FTDI

You’ll see a line including either com.apple.driver.AppleUSBFTDI (for the driver from Apple, which we recommend using) or com.FTDI.driver.FTDIUSBSerialDriver (for the driver from FTDI, which we recommend against). It’s also possible that you’ll see them both. If both are present, then your computer will use the driver supplied by FTDI.

You can uninstall FTDI’s driver using the following command:

rm -r /Library/Extensions/FTDIUSBSerialDriver.kext

The FTDI driver is not recommended on recent versions of OSX.

1 Like

I STILL have this issue. OSX 10.13.6. I went all through FTDI drivers, and found no help in switching out. I then setup a raspberry pi with the linux drivers and x-carve server and use ncat to port forward network ports to its serial. I found that if I disconnect while the browser is still open, I cannot connect to the x-carve again without a full reboot. So that takes out any local serial driver issue. The ncat process can be stopped easily. The only thing left is the browser extension, but I cannot figure out any way to “unload” it short of a reboot. I have found that if I fully quit the browser while still working, then close the ncat session and power off the x-carve, sometimes I can reconnect, but even that is circumspect. I would really, really, appreciate a better web extension for OSX that doesn’t lock up. I almost never have to reboot my laptop, unless I use it with the easel web app

Yes STILL an issue for me as well.

On my 2015 Mac Book Pro with 10.13.6, X-Carve will only connect once per USB port.

Additionally, after this happens, that specific USB port is rendered useless and will not connect to other reliable devices such as both my normal printers. Ports that were not used with X-Carve remain functional.

Reboot always fixes it.

I am having the exact same issue. Has anyone found a solution other then rebooting?

I am having that same issue. However, I was able to make to the Z probe set up twice. Both times getting to the 3rd step of " Touching the plate to the collect" and nothing. I have backed up and restarting this dog gone thing so many times. I have spent 3 hours lastnight and 5 hours today so far… I have downloaded all of the drivers, restarts etc… This is driving me nuts!!!

1 Like

Tengo ese mismo problema. He hecho todo lo que ustedes han hecho y es desagradable saber que tengo que reiniar para reconectarme ma ha pasado lo mismo con mis dos computadoras una con windows 10 y otra con windows 7.

I’m also having this issue. I turn off the x-controller and then I’ll always have to restart the mac to get it to connect to the x-carve/x-controller again.
I’d love someone to tell me what’s going on

same problem here

I am working with Chrome but have not had this issue yet. Every now and again the machine will ask me to reconfigure but that is only if I have not used it in a few days.

I’m also having this issue. It’s been driving me mad for months now. I’ve tried different USB ports, USB adaptors, different leads… nothing. Safari and Chrome, same problem. For a while I had to reinstall the driver and then reset to get it to connect.

I tried @JeffTalbot s suggestion with the terminal command and got the following response:
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release

So I don’t know what to do next. Did anyone ever solve this?