Easel Pro drills a hole first every time!

If this has been asked before I apologize but none of the keywords I tried got me any answers!
I used Easel Pro today (a free day) to carve letters of the alphabet into segments that will be used to make a feature ring in a segmented Beads Of Courage box. Every time it started to carve a letter the first thing it would do is drill a hole straight down ~10mm. The weirder thing is that I carved two instances of the letter A and it drilled the hole in a different location for each letter. The hole usually is carved away when the letter is carved but sometimes it’s on the outer edge of the letter and will interfere with my filling the letter with Pouring Compound. Does anyone else have experience with this or am I just Mr. Lucky today?
You can watch the 13 sec. video if you like:

Possibly the same as issue discussed here?

Thank you, Neil. Very interesting and really annoying. If I was one of the people paying for Easel Pro I would be very upset! The fact that I’m using free days helps but the loss of material and the time I spent preparing the segments is still not making me a happy user!

Same here

@GordRock Can you share the project?
@PaulRinguette had an odd issue that seemed to be related to the nodes in his artwork.

I haven’t done this before but I think I have shared it properly.

First time I generated toolpath…looked ok for the B, but I saw the full depth plunge on the E.
Went back to the B, generated toolpath again and got this: (different location from your video)

Generated it again and got this:

If I click to another letter and back to the B, it sometimes switches locations again.

Looks like the same bug in the other thread I linked above. @Ruwan

On the plus side, people have been begging for a drill operation in Easel. :wink:

1 Like

Thanks for checking this out, Neil. As I said in the original post, carving two instances of the A I ended up with holes drilled in 2 different locations.
Yes, if they could take this bug and isolate it to use as a drilling feature that would be great!! As it is, not so great!!


I think the design was created in Easel…not sure if you can do that.

Thanks Phil… didn’t think to look under the apps.
@GordRock, I’d give this a try. Check your toolpaths before you carve. Many of the other issues seem to originate from the way Easel handles the artwork.
EDIT: Never mind…Problem persists even after exploding.

1 Like

@NeilFerreri1 Thanks for checking it out!
@PhilJohnson Thanks for the thought, Phil.
@Zach_Kaplan I sure hope Inventables discovers what the problem is soon! Glad I’m not one of the people paying for Easel Pro! I would not be happy!!

1 Like

@GordRock yes they are working on it now.

When I changed to straight bits, on your file, there was no full depth plunge. When I changed back to a v bit, it created the plunge in the tool path. Could it be a v-bit issue in Easel?

I have the same issue, but I was not carving letters, rather some decorative geometric design for door and window trim. 3 cuts, 3 different holes, only 1 on the tool path. Also using easel pro for free, one of my 4 free monthly sessions. Also, homing seemed to be a problem, as the second attempt to cut the design using the last home position found the bit off by 1 inch on the y axis.

Hi @RobertMoore we’re sorry about that. @Ruwan will give an update tomorrow once they finish regression testing and push out the fix.

1 Like

Did you home the machine between cuts?

Normally I do, but on this second cut I instructed the machine to use the previous home, as I was attempting to cut the same design on an identical piece of wood in the same exact position. The third time I cut the design I did rehome it. Previous procedures not rehoming the machine while cutting in easel non-pro version have met with success, not so this time.

Probably more of a mechanical thing. Maybe you moved by hand? Or lost steps due to the random drilling?
I think they’d be better off using “Work Zero” instead of “Home”.
Home is where your machine hits the switches when you “home” it. Work zero, in Easel, is the lower left corner of the carve. When you set that zero, Easel sends a command that stores it’s location, relative to Home, and that will be the same until you intentionally change it. When you click, “use last home”, it just doesn’t change it.
The problem comes when you don’t actually re-home (seek the switches). Your machine is dumb…it may “think” it is somewhere it’s not.


We are working on this issue now. We will update as soon as we find a fix.

Thank you


Hi @GordRock and all,

We deployed a fix. Could you please check?

Thank you


1 Like