Easel pro misaligned text

I have been experiencing problems with lines of text carving misaligned I center my words on the work piece but when it carves the second line of text is misa;ligned also when it carves it carves a lot deeper than what I set it for and when you stop the carve because of misaligned text it does not return to the original home spot set when beginning carve I have uninstalled easel and reinstalled on another computor same results I am using a sainsmart 3018 any help is apprecciated Dennis Mariner7018@gmail.com I have made many plaques and this is the first one text has done this

Text misalignment and bit running deeper and deeper is a strong indication of machine malfunction.
Most likely from cutter forces exceeding the capacity of your steppers. The capacity of the steppers are also highly dependant on feed rate, at higher RPM the available torque drop.

so what do you suggest for a solution

Post your project, Easel - File - Share - Share publicly, copy URL and click Save, post URL here.

Also:
Open Easel, press CTRL+SHIFT+D and in the Console box type $$ and press Enter.
Copy/paste the list of $-values displayed below.

This is the only chance for us to have any idea what is “under the hood” of your machine.

Also, your controller board, which version do you use?
Might be based on the A4988 stepper driver chip which is weak and prone to overheat (and temporarily/briefly shut down as a fail-safe) causing loss of position.

It could be anything really, the the symptoms you are having are very inconclusive.

  • ok
  • $132=200.000
  • $131=200.000
  • $130=200.000
  • $122=30.000
  • $121=30.000
  • $120=30.000
  • $112=600.000
  • $111=1000.000
  • $110=1000.000
  • $102=800.000
  • $101=800.000
  • $100=800.000
  • $32=0
  • $31=0
  • $30=1000
  • $27=1.000
  • $26=250
  • $25=500.000
  • $24=25.000
  • $23=3
  • $22=0
  • $21=0
  • $20=0
  • $13=0
  • $12=0.002
  • $11=0.010
  • $10=115
  • $6=0
  • $5=0
  • $4=0
  • $3=2
  • $2=0
  • $1=25
  • $0=10
  • ok
  • [OPT:V,15,128]
  • [VER:1.1f.20170801:]
  • $$
  • $I

Events

Settings

$0=10
$1=25
$2=0
$3=2
$4=0
$5=0
$6=0
$10=115
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=3
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=800.000
$101=800.000
$102=800.000
$110=1000.000
$111=1000.000
$112=600.000
$120=30.000
$121=30.000
$122=30.000
$130=200.000
$131=200.000
$132=200.000

You have some extra geometry off your workpiece. (Right near X0 beyond your workpiece on the Y)

The machine tried to go further in the Y than it can handle. You crashed and it lost position.

6 Likes

When designing I have a “best practice” were I select all to be sure I don’t have any stray elements in my projects. HAs helped me a couple of times eliminate issues.

1 Like

Absolutely good advice.

CTRL+A = Select all

Good catch :smiley:

If that was me that would be a common clamp position…

Changing the subject to your settings, it will benefit you in the long run if you change $1 from 25 to 255. Just go into the Machine inspector and type in $1=255 in the command box and hit enter. This will tell GRBL to provide power to your stepper motors when they are idle which will prevent you from moving them easily while changing bits for two-stage carving.

Also, make sure that you have your Dip Switches inside the controller set correctly if you have an X-Controller. This forces the hardware to provide full holding current to the motors while they are idle.

Here is an image of the Dip Switches…
Capture

{:0)

Brandon Parker