Easel Pro stuck in "Simulating Toolpaths"

Looks great. Thank you very much.

1 Like

Im having the same issue anytime i use 2 bits and it gets stuck simulating tool path on the detail run. Im using a very stout pc so i dont think thats the issue. On my last project i simply turned it of and ran it again as a seporate project just outlining what was done with the rough pass and that worked ok but could have been better if it knew it was to clean up some of what wasnt done on the first cut. But this is my work around for now until someone fixes this glitch. Writing this on my phone so forgive any typos

Can you share the easel project causing troubles with simulation?

Thanks!

I’m having the exact same problem, which I have never seen before, it just started happening over the last couple of days.

In my case, it is an extremely simple SVG shape that it should not have any problems with, but it always is getting stuck. This has me in a bind trying to get the GCode file.

I don’t think processing power is an issue as I’m running this on MacBook Pro 14" with an M1 MAX processor.

1 Like

Hey Robin, id love to help. Can you share the project?

Hey Seth not sure if anyone shared their projects for inspection but I am having an issue getting my toolpaths simulated as well, i know its alot of steps but i have a beefed up computer and i have closed everything out except easel. thanks!

That is a lot of nodes and objects, close to 20,000 nodes and 7k objects…

Or you could import the .svg to inkscape and use the simplify function to decrease the node count as needed to get it to calculate out.

Or you could try covering a large portion of the design with a rectangle set to 0 depth and it’ll calculate smaller portions and you could carve each of those portions one at a time.
But the calculation still has to think about the nodes that are covered so the toolpath could still take the better part of an hour.

BTW Decreasing the safety height will also reduce the carve time, this setting is in Machine>General Settings.

I suggest simplifying the design by reducing the node count first.

2 Likes

Thanks Seth, I went into Illustrator and erased alot of the nodes, still takes about 15 mins to simulate but better than nothing, is there a way to simulate BEFORE the spindle turns on, or is it not a big deal that the spindle spins idle for that long?

1 Like

You can export the gcode and reimport it and run the cnc using that imported gcode.
the sim will run when the gcode is saved and not when the carve is iniated using this method. :+1:

It’s an undesired extra step for sure, but it’ll keep the spindle from running during that time :man_shrugging:

1 Like

Ill try it!

1 Like

Hello all,
I have been having an issue with downloading my Gcode from Easel to my machine. I was able to send it, until i changed the bit. it gets stuck about a 3rd of the way through “simulating Tool Path”.
I tried using a roughing pass and a detail pass and it stops in the detailed pass. I’m running a dell Latitude E6540 with windows 7, my machine is a DIY 3018 pro with expansion kit. I use GRBL 1.1.7.
Does anyone have info that may help? I did attach my project.

Thank you,
Curtis

I think the main issue is that youre running a 2 bit carve in a nonstandard way. This is how youd want to setup a 2 bit carve with a roughing endmill and a vbit for the details.

There is too many stepovers using a 20⁰vbit to make the whole pocket area plus the stepdowns used caused wayyy too much work for your PC to process.

Thank you Seth. i did everything that same way. I’m not sure why else I’m having issues.

thank you,
Curtis

1 Like

Hey Curtis, the link from before appears to be broken. If you can attach the current one I can take a look at the file again and record a little video showing what I might change to get it to properly simulate out and be able to save the gcode…

Seth, I appreciate it. I deleted the old design and started from scratch. I got it to simulate out all the way.

Thank you,
Curtis

1 Like