Easel Script Error Locks Up

Can anyone help me? I am trying to load a program to drill a waste board that will cover my Inventables one so I don’t ruin it. I worked it up with Sketchup 8, exported it as an SVG. Then when I try to load it in Easel it starts to load, I get the box that asks if I want to scale it down, I say no, then I get a script error and Easel locks up. I read the posts, and tried the same thing in Chrome, but it did the same thing. I am using a newer laptop, with windows 8. I can load it fine in makercam with no problems, except I used ugs, and tried to cut it out and the holes were right for the first ten or so, then they started getting drilled in the wrong locations. I will add my SVG to see if anyone can figure out if I am doing anything right. Thanks in advance for the help .skp">sm wasteboard 7.skp (60.8 KB)

Did you change your work area to 31X31" any chance.

In Easel, I can’t even get to the part where I tell it the actual workspace size. It locks up and gives me that script error message. I tried the same thing in Chrome, and same thing happened. When I tried using makercam, and ugs it worked for a bit then after the first ten holes, it went off course and started drilling holes in the wrong places.

Can you share your project and post the link here?

Jeff I would love to if I knew how to do that.

Normally, you could just click “File / Share” and then choose to share with link. However, if your project is locking up, you might not be able to do that.

I looked up the SVG file you are trying to use in your account, and I tried importing it. It looks like it imports into Easel just fine, but then Easel chokes trying to generate the toolpaths (which it uses to render previews of how your job will look after it’s cut on the right side). In particular, it seems hung up on the first step where it assigns objects that intersect to groups.

I’m not sure why that is happening. We’ll have to examine this more closely tomorrow. I did notice that the SVG seems more complex that it should need to be. It seems to be using many small lines to draw the circles, rather than actual circles or ellipses. Still, that shouldn’t cause Easel to hang like it is.



Thank you sir, tomorrow will be just fine, there is no rush, I am just slowly working on different easy new projects to get used to this cnc process. I will be happy to try and share everything I have on this. When I go to the file, right click and click share file with, it wont let me add the link above, or I am telling it the wrong thing. Thanks again.

Hi @RonSwanson,

We pushed some changes that should allow you to work with this project now. I was able to import your SVG and interact with the project, although it does take a while for Easel to generate the toolpaths. If you are able to rework your file so that it is composed of circles instead of tiny lines, you will likely see a drastic speedup.

In the future Easel will be able to merge all of these tiny lines into polyline objects as well.

Hope this helps,

Jeff, thank you for all the help. I will give this a try first thing tomorrow morning. Thanks again. Ron