Easel seems to be in reverse

How do I fix this?

Y+ makes the router move the spindle south from its machine Home position which is top left corner
Y- makes the router move the spindle north

X+ makes the router move the spindle right from its machine Home position
X- makes the router move the spindle to the left

My carving is coming out in reverse/mirror. How do I fix this?

Thanks in advance.

1 Like

There are 3 fixes for this: the simple way with software, the harder way with software, or the PITA way with hardware…

Simple method (my preferred method): redo the machine setup in Easel (Go to Machine>Setup New Machine), during the process there is a page with a grid and some yes or no questions regarding the operation of each axis, this step is commonly skipped over, BUT by answering these questions properly Easel will automatically correct the grbl setting that controls the direction of travel for you.

The harder (manual) software method:
you can manually do what Easel does in the simple method by opening the Machine Inspector page in Easel (press ctrl+Shift+D to open this page, or go to Machine>General Settings>Machine Inspector to navigate there) and scroll to the bottom of the page where you’ll find the grbl settings. Read the value for $3 and then plot the current setting on the chart below. Then select the new value that changes the axises that you need changed. Then scroll back to the top and in the “console” section type the new setting value just like you want it to appear in the setting list below and hit enter to send the command to the cnc where it will be saved until updated in the future…

for example IF your current setting is $3=1 and you need to chance Y and X . the new value to use is $3=2 because i kept the Z setting as it was, a “N” value, and I altered the values of both X and Y respectively.

The 3rd and final method is to re-wire the stepper motors to reverse the direction.
**AND IF your problem was the Y axis only and you’ve got an X-Carve or other Belt driven CNC, this would actually be the simplest for reversing the Y only because you could swap Y1 and Y2 and that will invert the movement of the Y, but since you need to also swap the X, the Easel setup is by far the fastest/easiest fix.

Merry Christmas!

I read the instruction to change the software to make Y+ go south and Y- go north but the homes switch are located on the top left corner.

When I hit Home the software is trying to go to the bottom left corner.

I cannot reset this. I tried to reinstall the machine and now every time it is going south even after deleting the machine and reinstalling it.

The following dialog does not do anything and it is in a loop:

What I meant is that this dialog is not fixing the Home settings and it goes back to Start homing sequence button and nothing happens.

What am I supposed to do?

The following is my setup and what is happening.

  1. The home switches are located at the top left corner.
  2. The machine is trying to home at bottom left corner
  3. before making this change the machine was carving in reverse but it was homing correctly
  4. I have not tested the machine with the incorrect homing settings

What machine do you have? Don’t run the setup through easel if you don’t have an Xcarve.
Change your $$ Grbl settings.

This is simply an issue with your firmware setup, not easel.

You want to change your $3 value as @SethCNC mentioned to ensure your machine jogs the correct direction. Then you’ll change your $23 value to adjust homing direction using the same input mask table.


Just jumping back in to say that what Neil said is totally correct.

Fix jogging directions via $3 and THEN adjust $23 to home into the corner desired, both using the same chart :+1:

If you run the easel setup and don’t have an xcarve. Make sure to select “other 3rd party machine” and it won’t charge your calibration settings… it used to reset all machines calibration settings to be incorrect in the past, but they fixed that issue late last year :hear_no_evil:


I appreciate your help! I tried the simple method of setting up new machine. Still doing the same thing, Z is sporadic, doesnt follow command and sounds as if it isnt giving the full cycle. I have checked for binding, loose wires. Could it be a bad stepper motor?

Not likely.
Do you have any more info? I don’t see any other posts from you on this thread.

his reply appears to be a follow up to this thread, where he reported inconsistent Z axis movement, sometimes up and down jog causes opposite direction movement… In my experiences this is an indication of loose wiring causing the phases to not sync properly all of the time on an intermittent basis. . maybe you’ve got another point of view to address this :smiley:

This is usually the case. If it always happens at a specific XY location, there might be damaged wires. My guess would also be a loose or bad connection.

1 Like

I updated the firmware and reset the X,Y,Z and now the CNC is working properly. I think that the firmware update flushed the firmware settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.