Easel setup

Is there anyway when you load up easel and when you click on Machine mine always says x = 11.5 and y = 11.5 and I alway have to go in and change it to 31 and 31 but if I logout and log back in it’s back to 11.5 and 11.5 anyway to save it so I don’t have to do that all the time.

I have another question about Easel setup. I have a ShapeOko v1.4 with a grblShield v4. When I start carving, the direction and distance moved is off.

For X (left / right), the direction is correct, but each inch moved in the program translates to 5.7 inches on the ShapeOko.
For Y (forward / back), the direction is reversed, and each inch moved in the program translates to 5.7 inches on the ShapeOko.
For Z (up / down), the direction is reversed, but the distance is correct.

On Y and Z, swapping the black and green wires fixed the direction issue. Now there is no issue with Z, but the difference in distance for X and Y is still an issue.

On the grblShield’s original setup, Z has a jumper on the left two pins, and X and Y don’t have jumpers. When I remove the Z jumper, one inch translates to .25 inches on the ShapeOko, so it seems like the left two pins translate to a X4 setting (not X2 as indicated in the following image: https://camo.githubusercontent.com/3a051e30398faa3e25d8ca0c3b321cdc217845d9/687474703a2f2f6661726d392e737461746963666c69636b722e636f6d2f383337372f383530333639383934355f643833623332373734652e6a7067). When I put the jumper on the left two pins for Y, 1 inch translates to 22.5 inches (not the X4 as exemplified by the tested Z settings. I’m going to try other jumper settings, but since putting the jumper in the same position for Y as Z didn’t produce the same results, I’m doubtful other positions will be better.

I’m not entirely sure how to proceed. Any advice would be sincerely appreciated.