Easel Stepping Too Far in Z-axis (S2 w/Acme & NEMA 23 Z)

I’m having an issue with Easel making Z steps that are too large, on the Z axis only. I have a mostly stock Shapeoko 2, with a Dewalt 660 router, ACME Z screw, and a NEMA 23 Z motor, to handle the extra weight of the router. The X and Y precision seems to be right on, but the Z axis is making steps that are much too large. The only configuration settings that I could find, in Easel, are the selection of the Z axis screw type (I did pick ACME), and the feedrates. Has anyone else encountered this problem?

I have $2 set to the recommended value, in GRBL, for the ACME, being 188.947. I used UGS to do that.

Any advice would be greatly appreciated.


  • Alex

Sounds like you are still using Grbl version .8. Upgrade to .9i then run the setup again.


Ah, very interesting! Does Easel assume GRBL v0.9, at this point? I had stayed away from the GRBL upgrades, so far, because my 0.8 setup has been very stable.

Does 0.9 handle the Z axis in a different manner? How does it help?

Many thanks!

  • Alex

I thought the same as you, I had Grbl .8 and it had been working great and the thought of loading a new version made me very nervous. But after the upgrade Easel was having all kinds of issues that I could not explain. My Z axis was moving very oddly and the X and Y were moving very slow.

I did the upgrade (which was a huge pain till I found the XLoader. Even then getting the Grbl .9i hex file downloaded was trouble since the link to it on gethub would just open the hex file in my editor.

I think I finally found a link to a version that would download correctly
grbl_v0_9i_atmega328p_16mhz_115200_for_SO2.hex (78.6 KB)

Good luck

I just figured out the problem, and it was quite obvious, in retrospect. I installed Improbable Construct’s belt-drive Z-axis mod, to increase the speed of my plunges, and that introduces a 2-to-1 reduction in rotational speed, so my $2 should be 94.4735, and not 188.947.

However, Easel automatically does machine setup, and sets my $2 to 188.947, based on my use of the Acme Z-axis. Is there a way to work around this?


  • Alex

Doesn’t Easel just do the setup once, when you go to /setup? It seems like you could do that once, and then use another tool to set your $2 value.


Indeed it does, but this will get reset every time that I need to change an Easel machine parameter. I was hoping for a custom multi stepping setting, or something like that, so that it would be correctly set.

I am actually doing that, using UGS to set $2, and then running Easel, now. Was just hoping for a fix, rather than a work-around. I am not sure how common my S2 mod is, though.


  • Alex