Easel stops one every project without a reason

Hi!
Completely desperate here. Easel just stops cutting in the middle of the project. Everything goes well, then suddenly a “How did it went” dialog appears, then it just stops. There is no tension between the bit and the surface, it could easily continue.
So far I:

  • tried different USB cables
  • tried different internet connection options
  • tried different browsers
  • my cooling is efficient
  • all screensavers and sleep options are off
  • checked all the mechanics, all tight enough
  • cut settings are super safe
  • bit is secure
  • all other electrics (vacuum, spindle etc) in another outlet
  • arduino and laptop are plugged in electric outlet with surge protection
  • updated all i could update

worst part is that i can’t recognise the pattern, or where it started. i was working fine for quite long time, that this thing started to happen all the time. total frustration.

setup:
custom Shapeoko 2, arduino+gshield, Macbook pro, Makita RT0700

this is the last one that stopped:

You got a spare Arduino to try?
Any fluorescent light bulbs nearby / on same/close circuit?
Got homing/limit switches connected?

Thanks, but if you look at the troubleshooting steps i already did, you might guess that i read a lot about the topic. But yes, topic is quite popular…

Hi,
thank you for reply.

  • no spare arduino unfortunately.
  • hm, yes, there is one. very simple desk lamp, sort of like this one:
    http://www.chworkspace.co.uk/img/p/337/p-zoom.jpg
    it was there for ages without causing any troubles before. I will try to run a cut without it.
  • no limit switches.

so, the problem looks software - related. i was running the same job over and over to see if there is a pattern. it stops at different places, sometimes stops, sometimes going completely off-path (after short stop), most often it happens at 8-10th minute of job. like, there some impulse happen that cause to stop the job. (my vacuum hose is grounded).

I have a very similar setup (Arduino/G-shield/Mac/Makita) which I had connection issues with.
Knock on wood, its been very good for a while now.
I havent tested my theory that DC motor at high RPM is worse noisewise than same motor at low rpm (speed setting 1 vs 6 for instance, I usually just run mine at 1)

My changes have basically been:

  • Shielded USB cable, short and with ferrit cores
  • Provided distance between Arduino and AC-power cables/source
  • Provided distance between stepper wires and Arduino

Thanks for reply, Haldor!
so what material do you cut on speed 1? I guess it would be a bit weak for my needs - plywood. But i must admit, i was freaking out because of the problem and turned the Makita to 5-6 just to ensure it is not a mechanical problem, like stucking in material and not being able to cut.

  • will go buy proper USB cable
  • will make some distance from AC cables (actually now Arduino is right there close to outlets)

didn’t get this one. what you mean? stepper wires goes into gshield, which is plugged into Arduino. Separating Arduino and gshield would be a soldering challenge and will make all the construction very loose.

so, braking it all, you think it is some sort of electric interference that cause Arduino to freak out?

Yes, based on what I have experienced myself and what I have read here from others is that there are two main causes for interuption.
1 - Electrical noise, causing USB dropout
2 - USB power management interupt
The USB is the weaker link, but oh so conveniant :wink:

With the Makita I mainly carve aluminium and some PVC, speed 1 for all. At 10k rpm is is usually plenty fast for most wood etc. A router ability to carve is related to torque, not RPM alone. The RPM governor of the Makita does a fine job keeping it up :slight_smile:
An electrical motor provide max torque already from its first rpm :grinning:

Regarding keeping stepper wires away from Arduino (and USB cable) I meant minimizing wires in close proximity to the Arduino/USB cable.

If your system used to act nicely but have started to get worse, check your Makita motor brushes for wear.
Brushed motors (like Makita use) have carbon brushes that conduct electricty to its communators, when these segments engage/disengage it may cause small sparks. This generate EF noise.

For kicks, run a carve with the RPM at its lowest setting. I suspect you have nothing to fear unless you run at insane feed rates, depth per cut :wink:

Thanks Haldor,
those are definitely steps to check. Now when i look back, i remember everything went well when i was cutting at low RPM (but again, maybe it is because those were just small jobs).

My Makita is only 2 months from the shop, i hope brushes are not wearing out so fast.

I recently chased very similar elusive issue and to be honest I’m not 100% sure I fixed it. What it did for me was trim and redo all the connections on motor wires and I have not had it happen to me since.

Thanks, Robert!
Well, been considering this, of course. Read number of articles and forum posts on the topic. I guess wrong current mostly causing missing steps as motors behave differently. Mine was working perfectly until that systematic stopping started to occur. So i didn’t want to touch the current settings and fixing what is not broken. I have a proper cooling, sometimes check the drivers with the finger, they are never hot. Also, after comparing my settings (visually evaluating the knobs) with what users with similar system reported as successful, i realised mine are just right.

Now i am thinking to go all that shielded wires and isolation routine.

Was thinking to do that, but… all motors are moving. And overall performance is very good and i am happy with precision. Even if there would be a loose one, would it cause to stop the system and send a “how did it went” dialog box in Easel. I guess no, it would just go off path.
hm… actually i just figured out how i can eliminate the problem: run a test carve and disconnect the usb cable, if it stops and sends the “how did it went” dialog, then USB dropout is my case and i work on shielding and isolation and stuff.

I did that turned off a router, dust collector, lights and it still stopped.