Easel stops working in middle of project

This has happen twice I’m about 90% complete on the carving of a project and I get an error that the program stopped or the internet stopped. Easel goes back to the screen where you would start the carve program so I don’t know how to continue the project to finish the last 10%. Is there anyway to send to carve to a memory buffer first so that I don’t have to worry if the program is going to stop working.

@GeorgeHenry Easel doesn’t require the internet send a carving project to the machine.

Can you please either share the file or post a screen shot of what you are seeing so we can investigate?

Not sure I was saying it correctly. I use Easel to create the art work then send it to the carve. This needs to be done while on the internet. So as it’s carving the internet needs to stay up and running if the internet goes down then the carving stops. This has happen once when I was about 90% complete. The Second time if I remember correctly the program error-ed and the carving stopped again somewhere around 90 to 95% complete. The program went back to the screen where you would start the process to do a carve. I’m looking at Universal Gcode sender as maybe a solution only it looks like there a good deal of learning that I don’t have time for right now. My question is 1. it would be nice to have stand alone program that I don’t need the internet in order to run say example (win-easel) that I can do my art work then send to carve just like a printer is done or 2. If I can send the easel art work to a memory buffer then to carve then if the program errors out the carve still works because it’s in memory something like a laser printer that has 8 meg of memory once it sent I move on. Hope this explains better.

I am encountering a similar problem where easel just stops cutting in the middle of a project. I cannot find a way to finish the project. Even if I reset the machine to the exact same home position and try to start over the new cut is far off from the original and screws up the whole project.

@AaronMaun what OS and browser are you using?

Can you start and stop a job and click “No there was a problem” so I can see the error report?

Also have you tried another sender and it completes successfully?

Are you using homing?

If so can you please, power cycle and refresh the browser, then try to run a carve without homing the machine but setting the 0 manually in Easel?

I’m using mac iOS El Capitan with caffeine app running and I’ve ran the project with homing and it is currently running on a manual zero. I’ve also tried going through safari and Firefox with no differences. I have stopped this project a few times and sent a report.

Did it ever stop while using a manual zero?

Yes but that is when easel and safari just completely shut down and had to restart the browser and open easel again

Have you been able to run it successfully with a manual zero?

Can you share the file so I can take a look?

This is the file i am attempting. it is missing a few drill holes because my detail bit cannot carve them deep enough. I have not had 100% success for this job because of the machine stopping, my browser crashing, or the problems with two stage cuts. I’m currently running another cut with manual zeroes which is 27% done.

@GeorgeHenry to clarify Easel needs the Internet to load or save your design. It makes a direct connection via a local socket to the easel driver (native app you had to install) to communicate with your machine. The 2 connections are independent. Once the file is loaded you don’t need to be connected to the internet to carve on your X-Carve.

Is it possible to provide more information behind “the program error-ed and the carving stopped again somewhere around 90 to 95% complete. The program went back to the screen where you would start the process to do a carve.” What do you mean by “the program error-ed?” Did they you see an error message of some kind?

@aaronmaun to figure out the root cause it helps if we can isolate the variables. Would it be possible for you to continue only doing carves with manual 0 for awhile to see if the same issue happens again? One reason this can happen is the wires for the limit switches cause electrical interference or your machine hits soft limits and it will throw an alarm state. If you don’t home it in the beginning and manually zero it then it takes the limit switches out of the equation.

i will continue to experiment and give feedback. i just can’t wait to test new features as they roll out

Now I confused as I was cutting a name plate on a 12 inch by 3 inch board the x-carve was carving perfectly when al of the sudden it stop with about maybe 10% left to go. I looked at the screen on the computer and it said internet lost connection. SO I assuming that meant it was being controlled by way of the internet. I haven’t tried this but are you saying after I send my project to the X-carve I can close out the internet and it will still keep carving. If that the case why is it that I read that if the screen saver kicks in then the project stops. I have a 3d Printer after sending my project to it I can shut off my computer and leave and it continues to print that what I’m asking if the x-carve can do.

Did you figure this out or get an answer to this? Interested because this is starting to happen to me all the sudden…

I’m trying to remember because it was so long ago but I think I did two things 1st I made sure my screen saver was shut off while I was carving my about 5 minutes into it my screen saver came on ad stop the carving the other items was I was using a wireless and I changed to a cabled to the switch internet connection. I personally would rather have the easel as a stand alone software that ran from my computer and saved on my computer but it is what it is. once I did these twi things everything workd. Hope this helps.

1 Like

@Zach_Kaplan was this root cause ever confirmed?

I’m not sure. Our software engineering team has been studying this problem. Apparently there were multiple causes. They have made a number of changes to the Easel Driver and released new versions that are supposed to address many of the issues.

I don’t know if all of them have been addressed on all OSs.

Have you installed the latest Easel Driver?