Easel update not working [Resolved]

I just tried to make a few quick simple parts just like always, design in v-carve and import g-code to Easel. Tried the download…did not work, tried the prev version .32? that did not work either. Tried going back to earlier version but it constantly tells me to update my driver! had to resort to Chilipepper (not a fan) to get the work done.
Is there something I should be doing? some additional step?


1 Like

I can second I am having the exact same issue. 0.3.3 didn’t end up working, and downgrading to 0.3.2 didn’t work as well. Constant ‘you need to update’ message when trying to use.

I’m on a mac - I’ve tried Chrome and Safari browsers, both without success.

we have had a few reports and we are looking into this issue. I hope to post an update very soon.

1 Like

I have been unable to get jobs to complete since the new driver as well in firefox, chrome and safari on both mac and windows today.

Reverting to driver 0.2.7 results in jobs starting but failing soon after.

Reverting to driver 0.2.5 seems to work better. definitely getting through more of the job before failing.

I will be able to check this afternoon.

Side note this forced me to use the offline method with UGS and that works great.

1 Like

All I can find is EaselDriver-0.2.7.pkg and yesterday this was not running job to completion.

Hi Folks,

The problem seems to be an issue with the service manager pausing or stopping Easel, and unfortunately our developers have not been able to reproduce the issue on their end. If all is working as it should there are two logs created, located in C:\EaselLocal\iris.error.log and C:\EaselLocal\iris.out.log. These logs provide the most insight as to what might be going wrong with Easel. Feel free to send those logs to help@inventables.com and we can have our developers take a look.

If the Easel driver is not able to start, that means it can’t produce the logs that contain information to diagnose the problem, and we’d need to look into why it didn’t start. In Windows, the driver uses a service called nssm to start, and nssm logs to the EventViewer, so if it’s unable to start the Easel driver it may log the reason to the EventViewer. Specifically, we would need to see the Windows Application Logs from the nssm source. You should be able to sort by the source column to more easily find those messages. For those affected, if this seems a bit too complicated, please give our help team a quick call at 312.775.7009 and we can help you further.

Downgrading seems to be helping for some. The few reports we’ve had where Easel version 0.3.3 doesn’t work have been fixed by downgrading to version 0.3.2. Unfortunately some of these cases might simply be unrelated, but are manifesting in the same way. Hopefully future Easel diagnostic tools will help us better determine the true root cause of issues like this.

1 Like


Any idea where those helpful log files might be located on a Mac?

Appreciate the quick response(s).


I finally had time to check the error logs and to my surprise all it said was “THIS VERSION OF WINDOWS NOT SUPPORTED, USE WINDOWS 7 OR HIGHER”
I then uninstalled every trace of easel local and then downloaded .3.2 and it works! Seems like version 3.3 does not support older versions of Windows (I am on Vista SP3)
I know windows seven and higher does access file structures differently so for now .3.2 will work for me since I am not about to upgrade to a newer computer just for the X Carve. My Win10 desktop is in my office and all my other systems are Vista.


I can safely say .3.3 works fine with win10 tablet and no errors show up, just ran a 22 minute project just fine. The regular Vista computer I use in the shop doesnt want anything to do with version .3.3 but works ok on .3.2.
I would use the tablet but my daughter might have something to say about that :open_mouth: