Easel / X-Carve fails to start carving

A surfacing pass ran just fine, but after setting up a two-bit carve and starting the normal sequence for the roughing pass, the sequence was normal until I clicked start. The toolpath generation began and completed, but the “Carve” button flashed blue and then returned to green and then nothing else happened. Tried several times with the same result. Went back to an old single bit project that previously ran without issue and had the same problem. The weird thing is that the surfacing pass will work every time?!?! Another note, before this all began I was prompted to update the Easel drivers and did so. Computer was rebooted afterwards like normal. Any help or suggestions would be greatly appreciated.

1 Like

Is the carve too small for the bit chosen?

1 Like

No, I can simulate and generate toolpaths OK, but when the toolpath generation is done it fails to start the carve. It also did th same thing on a carve that I did previously without any issues.

1 Like

Try to clear your cache, and even try an alternative browser (Firefox allows you to extend network timeouts). Also take a look at your task manager to see whether the memory is maxing out.

Failing that, I’ve had this issue with overly complex 3D carves (and I ended up using Fusion 360 to generate the g-code as a result). I believe it’s a memory issue, but suggest you call Inventables support.

1 Like

I sent an email support request but no answer yet. I doubt it’s memory as my machine is an AlienWare machine with 32GB and a 2 TB HD with 50GB virtual memory. Will try clearing cache and see what happens. Also saw that sometimes a Wacom tablet driver can interfere so I deleted my Wacom software and drivers as well. Noted that the Wacom interference was mostly seen on MAC OS but will try on u Windows machine as well. I’ll probably wind up calling support …

yeah - I hear you. My issue with the detailed pass not starting in 3D was also with a Razer i9 with 32 GB… in the end I abandoned Easel toolpath generation and recreating the carve and toolpaths in Fusion 360 and passing the g-code across. Big learning curve though…

1 Like

I’d make sure USB selective suspend is not enabled… Windows has this enabled by default and they’ve relocated this setting twice already in Windows 11, so you may need to google how to disable and hunt this setting down…
Also, you might try downloading the goce, then re-importing the gcode, this will eliminate the delay after pressing carve since there’s no toolpaths to calculate since it had already calculated prior to saving the file and now it’s just sending the text lines…

Thank you very much for your suggestions. It is a very strange problem as all of the other functionality still works fine, such as jog and move and the problem only occurs after running through the Easel sequence. The Easel sequence works normally, including the z-probe functionality and switching on the spindle, up until the time your click “Start” to start the carve. Then the toolpath is generated and the carve button flashes blue then back to green, then nothing. You can actually press the “Carve” button again and restart the sequence as if you never just ran the same sequence. Again, an older surfacing job still runs just fine, but any other job has this issue. I will try the export g-code and re-import to see if it makes a difference. That’s a great idea … thanks!

1 Like

So I cleared the browser cache and tried again with no success. Then tried to export the g-code and re-import it and surprise! The roughing pass proceeded to “carve” (was running without spindle on or bit installed). However when I next tried the same g-code import for the detail pass it again failed to start carving. Closed the project and reopened a new project and imported the detail pass g-code again but no joy. This strange behavior just started after the release of the 3D capability for Easel. I am using Chrome as I always have with Easel, but will next try the Edge browser to see what happens.

just a heads up here, Edge is also based on chrome code, so you’ll get similar if not identical or worse results. I suggest Firefox as an alternative because it allows some user settings to access more RAM and possibly overcome the issue.

Also if you like you can share the project and I’ll give it a try on my PC.
To Share the project in Easel go to Project>Share then set it to “unlisted” then copy the link shown and either paste that link here or you can send it to me in a DM if you prefer that method.

Thank you Seth for all of your help! I spent an hour on the phone with Julie troubleshooting and she had no trouble with my projects running. During the course of our conversation she mentioned that some anti-tracking software can interfere with Easel operation and so I checked my machine and found that I had AVG Anti-track running. I turned off the anti-track functionality in the AVG suite and now Easel runs like it used to.

Thank you Julie and all for the help!

1 Like