EaselLocal setup stuck at "Verifying installation..."

I have a Windows 7 32-bit PC and while running EaselLocal installation it freezes at the 'Verifying installation…" The progress bar is 100%, the ‘Cancel’ button is grayed out and the Setup windows is non-responsive. Any ideas? Thank you

1 Like

What is this EaselLocal you speak of and how do I get it?

EasyLocal is a bit of software that installs on your computer so that you can use the Easel program that is on the web.

It is not a local version of Easel.

Oh sneaky sneaky naming convention. I got really excited for a minute. I have no WiFi in my garage…

Easel Local is the installed portion of Easel that allows the browser app to connect to your machine. It isn’t a standalone program, just a background app.

Being stuck at verifying installation means that the background service wasn’t able to start. Does trying to reinstall after restarting fix it?

No, reinstalling after restarting doesn’t fix the problem. Note, I have Virus software off and have my browser closed during the reinstall.

Odd when I goto Services manager EaselLocal has
Status: Started
Startup Type: Automatic

And I can successfully stop and start the service.

Guess it’s time to hook back up to my Shapeoko and see if Easel will connect/run.

I am having the same problem. Haven’t found a work around yet but it seems there is a solution.

I fixed my problem. I needed to turn off the firewall, anti-virus and Internet security during the install. Turn everything back on after the program finishes and it all works.

Having the same problem. Turning off the firewall and defender did not help me. Windows 10. Check.bat in the EaselLocal directory just loops.

Event Log System shows the following messages when attempting to start the service:
The EaselLocal service terminated with the following service-specific error:
The system cannot find the path specified.


The EaselLocal service terminated unexpectedly. It has done this 2 time(s).

Currently stuck.

Did you install Java? This program is normally blocked (by Norton) but you can install it. This is required to run the Java script.
You may need to turn off firewall, and other protection software during the Java and Easel install. Once it’s running you can turn on all your protections.

I ended up fixing my problem with this.
I found that the EaselLocal service was trying to run nodejs from the wrong directory.
The installer silently installs nodejs, but I already had it installed in another directory, which Easel didn’t realise.

I fixed the problem by, opening windows command prompt.
change directory to c:/easellocal
then run
nssm edit EaselLocal
which will open up a gui to edit the windows service. In there you can change the directory it’s looking for nodejs in.

Hope this helps someone else.

I have tried edit the nssm but still stuck
Please help!!

Thanks, hit the same problem. I just uninstalled my other copy of nodejs, and it now works. I’ll install back on after this carve and see what happens

1 Like

That did it for me.

Removing Node.js worked for me as well (Shapeoko 2)

I’m a noob, would you know how exactly would to do something like this on windows 10 x64? Any help would be greatly appreciated.