Inventables Community Forum

Electronic problem

I turned on my x-carve tonight and it connected to the computer and everything seemed normal. Clicked carve and the homing message came up (as usual). As soon as I clicked start homing, a message popped up that homing failed. I noticed that I could freely move the router assembly (x, y, and z axis). Normally, when I turn it on the stepper motors lock everything in place. I am trying to determine if one of the motors may be out or something wrong inside the control box. I did purchase the x-carve upgrade kit, which includes new stepper motors. Before I install that, I was hoping to determine where the problem was. Has anyone experienced anything like this?

The grbl setting of $1 =255 is what locks the steppers anytime when it is powered on, can you go into Machine inspector and verify the grbl setting for $1?

When you are in machine inspector you can also trigger the x,y,z homing switches by hand and verify that they indicate as triggered, this will ensure that the switches and wiring are not the reason the home failed to begin with

2 Likes

Where do I find machine inspector? I use Easel. Is it in that software?

Found it. When I open it, the X, Y, and Z are green. When I press the switches, they turn white. This seems backwards…

1 Like

Yep, it’s different that standard, should be 3 pins on the switches,
no = normally open
Nc = normally closed
And the center (i think) is the signal

Just swap the NC to no :+1:

Having them the way they were can be useful in certain circumstances, but not commonly used

“Just swap the NC to no” – Not sure what that means…

Your switch may look different, but may be labeled similarly…

Here we can see the Com is the signal, and the nc is normally closed (this is how yours is currently wired) and the NO is normally opened, you need to take the wire off of NC and move it to NO.

Then the screen will be white and change to green when its pressed

1 Like

That made the lights operate correctly in the machine inspector, but still have the same issue. Won’t home, moves around freely. In the events section there are many lines with “error - error:9”

Error 9 is failure to home, can you copy all of the settings? At the bottom of that machine inspector screen

$0=10
$1=255
$2=0
$3=3
$4=1
$5=1
$6=0
$10=115
$11=0.020
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=25.000
$25=750.000
$26=250
$27=1.000
$30=1
$31=0
$32=0
$100=40.000
$101=40.000
$102=188.976
$110=8000.000
$111=8000.000
$112=500.000
$120=500.000
$121=500.000
$122=50.000
$130=750.000
$131=750.000
$132=100.000

All seems okay. Only thing to change is, if you set $20=1 then your machine will stop itswlf instead of physically crashing when there is a mistake and the carve size is too large,. But this shouldn’t effect the homing.

When it starts to home. Before the error pops up, it starts to lift z right? (It doesn’t try to go down, does it?)

The NC stands for “Normally Closed” and the NO stands for “Normally Open”. When the switch gets pressed, the “Common” connector gets switched from the Normally Closed to the Normally Open.

1 Like

No. It doesn’t move at all when I click on home. It doesn’t make any noise like it is trying. There is just a pause for about 15 seconds and then says failed to home. It seems like it can’t communicate between the computer and the CNC but it says it is connected and the machine inspector responds.

I had done several carves that day. Was just setting up to do the next when “something” happened. I wasn’t doing anything different. Just clamping board down and trying to start carving. Occasionally, communication to the computer is interrupted and I need to just turn the power to xcarve off, then back on to reconnect. I thought that is what was happening, but I am now in this predicament.

Any chance the e-Stop button is not fully retracted?

The USB portion of the X-Controller is actually powered by the PC’s 5V output, so it will connect and you can see and edit all of those grbl settings, and even tell it to move when the X-Controller is actually not getting 110V (like a tripped breaker, power strip, or the Emergency Stop button is pressed) BUT it won’t actually move without that 110V.

Also, I’m not 100% positive on this one, but I believe that the fan will not power up without the 110V, so you could check if that is even running :man_shrugging: if it’s not then it would be a giveaway that there is not incoming 110V … if it is running, well I might have guessed wrong and there might or might not be 110V

Fan is running and green power light is on. I pressed and reset the red stop button to make sure it is all the way up.

1 Like

In the console, when I check the “Show status” checkbox, I see messages like this:

  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P>
  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P|Ov:100,100,100>
  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P|WCO:-738.825,48.575,-52.906>
  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P>
  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P>
  • ?
  • <Alarm|MPos:0.000,0.000,0.000|Bf:15,128|FS:0,0|Pn:P>

I thought I might try deleting the machine from Easel and setting up a new one. I click on the delete button and it brings up the “are you sure” message. It won’t let me click yes and will not actually delete it.

To rule it out. Restart your computer.

2 Likes

I have tried that a few times. Also tried reinstalling the drivers.

When you haven’t touched the machine, except the power switch and it fails, don’t start rearranging the configuration or changing the basic hardware, such as limit or homing switches. Unless you have a gremlin that changes stuff like that at night, like the gremlin you won’t find it…

Your motor drivers which usually lock are not, assuming an OK motor, that is power or control board. If you have external motor drivers, that could also be a repairable problem area.

You can usually swap the connectors to X and Y motors set the head in the center and see what works. If when swapped, the other motor works, the motor is the issue.

It will not home properly so stop it when you know the outcome.
Always ensure they are the same type motors, which is typical.

Make sure you always make a copy of the working configuration before modifying anything. You can always go back to ground zero if you need to.

:smiley_cat: