Inventables Community Forum

Epilog laser won't go home, looking for miracle solution

Hiya laser community!

We have an 50W Epilog Zing CO2 laser. The Y-Axis keeps homing at about the 6.5" mark out on the ruler guide as if the rotary attachment were connected, even though its not. We do have a rotary attachment but seldom use it. After making sure the sensor was clean and belts tight, and even manually setting the home to factory default positions (X -152, Y +200) the dang rail continues to home as if the rotary were attached. We even tried connecting the rotary to see if that would reset it, no luck. I KNOW that Epilog will say the $1K+ control board needs to be replaced, but just wanted to see if anyone knew of a fix, or trick even.

Cheers! kwhopson

I have never had my Y axis screw up on me, it has always been the X. It was the sprocket on the X axis motor.
When my mother board went out the machine would power on but that was it.
Can you turn off the X and Y then move the laser to home?

Thank you for your suggestion. Yes, I can turn off X/Y and move the rail back to the normal home position, but as soon as I power off and on, or even reset, it returns to the incorrect position.

Did you try cleaning the sprocket?
Did you clean the strip that the sensors ride on?
The sprocket will get full of dust and when it turns the belt will slip

Blasted with air, visibly clean. I’m thinking that it is a control board issue, as does Epilog. I just find it hard to believe I need to buy a new one. Seems there should be a factory reset or a means to program the thing. The machine definitely is working properly in all regards to hardware, but is confused about where home is. Its stuck on the rotary home position, which seems like a software glitch to me.

Me too. Can you restore default settings or something?
How does it know that you’ve switched to rotary or back?

There is no Restore option in the Epilog driver interface, but the LCD display on the machine itself does have a Configuration menu that let’s you punch in the home position. I did, and it reads correctly, yet it still homes in the wrong place.

The Epilog Zing knows the rotary is attached once you connect it via its controller cable. Up until this started happening, it worked flawlessly, self adjusting to the rotary home when connected, then returning to the rear, left when the rotary was disconnected (always connected and disconnected with machine off).

I really appreciate any and all suggestions, just in case I overlooked something.

I’ve not used an epilog and our CO2 laser works much differently, apparently.
But from the Zing manual:

Use the Red Dot Pointer to set a new Home Position by pressing the X/Y Off key. Move the laser to the new Home Position
by hand and set a new Home Position by pressing the Go key.

Yup. In my first reply of this string, I note doing just that (though I neglected to mention the pointer).

Sorry. Assuming you’ve done the normal power cycles, unplugged and reconnected everything, and all of that, I’m of no use to you.
Good luck

If you take the side cover off and look at the mother board you will see 4 red lights. When mine went out I only had 3 lights. Once I took the mother board off you could see the small burnt diode or whatever the little piece was called. I have the 36 inch so your mother board may be different. I’m not at work or I could take a picture of my old mother board to show you.

1 Like

I’ll do a light count on Monday, thanks for the tip. Guessing you replaced the whole board, as opposed to the small burnt diode or whatever the little piece was called.

Yes I replaced the whole board, it wasn’t hard to change. I will take a picture of the board Monday and also the little burnt piece.

Did you figure out anything with your laser?

Thanks for asking. Monday and Tuesday got away from me, hoping to get back to testing the laser tomorrow. Will definitely post whatever we end up doing. In addition to this forum, I’ve also hit up industryarena.com, laserengraverforum.com, seemecnc.com, reprap.org and sawmillcreek.org in an effort not to sink over a grand into a new board.

1 Like

When the rotary is attached, there must be at least one wire in the cable that indicates the rotary status (The fact that it is connected )to the controller. A bad cable, or a bad connector/dirty contact could be causing the problem, which would cause the controller to think the rotary is connected when it’s not. The first thing I’d try is to remove both ends of the cable and make sure the connections are clean. If that doesn’t work, See if epilogue Support will tell you where to check on the board for the status of this Signal. At least then you’ll know that the problem is in the controller, and not a cable or connector problem.

Good suggestion, thanks. Tomorrow will be my day of reckoning.

To RussellCrawford, well, finding those red lights was tricky because there are no red lights. The only lights on the board are the green system status lights, visible without even taking off the cover. We did disassemble all the way down just to be certain there were no other lights.

To JohnJenkins, rotary connection and wiring seems perfectly intact. Followed all the way to the board.

Someone on another forum suggested reinstalling the driver but we all here agree that doesn’t control the rotary in any way. There are no options in the print driver software for anything beyond job settings.

Here is a photo montage for documentation that may help others in my situation in the future. We’ve pretty much given up, and plan to order a new board. Thanks to all for their great advice.

1 Like

Your mother board is smaller and the lights are green. Usually tech support knows what they’re talking about. Could you see any burnt spots on the board? I circled the piece that burnt

Read some very helpful things here, did you get it working as it should ?

I wondered if the z belt had actually slipped and the encoder on the stepper has a memory in EEPROM that it wants to be zero. Can you slacken the drive belt, return the frame to zero and then tighten it again. It may be worth a try.
Regards