Erractic first plunge

We have been using the x-carve for over a year and have had a problem with the initial z plunge the entire time. The machine has an acme rod, has a stiffened x axis and all belts, wheels, pulleys etc are tight. We are quite fastidious about setting 0,0,0 (z is set to one paper thickness above the work surface). The first plunge is erratic.
We set up a test to cut 4 pockets from 1/8" deep to 1/2" deep. Default Easel settings for speed and plunge rate we used. This shows one of the pockets during the second z pass:

Note the depth of the first pass compared to the second (and subsequent) pass. The pockets were all 1/16" to 3/32" deeper than modeled after completion.
We set up for another test and here is the first pass:

Looks close to the right depth! More tests and the first pass was too deep again.
Any help would be appreciated. We have several tweaks to make (steps/mm on all axes, planing spoilboard, etc.) but we don’t want to start those until we can solve this problem.

Hello, Gee… I have about the same situation. I am using Easel set-up process. I follow very closely the different steps prior getting the spindle to carve. Since day one (few weeks ago) I have been expose constantly to different depth measurements with the spindle versus the bit and the thickness of the board to carve. I am using the Z-probe device for the home point. I am still waiting responses from Inventables support team, I forward to their attention few emails and pictures about my set-up.

I am suspicious about the g-code loaded on the Easel software being different for almost every carve to perform. I hope that someone from Inventables get back to me ASAP… I have been making scrap carving…

forgive the dumb question, but is the ACME option ticked in machine setup?

I’m @LesKirk’s son-in-law also working on the X-Carve. I’ve had a DIY cartesian 3D printer for about 3 years now, so I’m somewhat familiar with the similarities and differences between the two.

Yes it is.[quote=“RobertCanning, post:4, topic:33208”]
Check the set screws that hold the pully on.
The set screws on the spindle/pulley are as tight as I can get them without bending the allen key. I’m at work, so I can’t check in person, but I don’t remember if I tightened any set screws on the Z motor gear itself (if there are any). I’ll make a note to check that.

We have gone with the default 188.976 setting since subsequent layers seem to be the correct depth. It’s the first plunge that’s definitely much deeper than it should be. Changing the Z steps would result in all layers being off instead of just the first, right? It’s possible that the Z steps may need further calibration after we figure out this “first plunge” issue.

I’ve also checked the GCODE coming out of Easel, and it looks pretty sane as far as that first plunge and subsequent layers go (comments are mine):

G1 Z0.15000 F9.0 ; raise to safe travel clearance
G0 X1.63763 Y1.38763
G1 Z-0.02800 F9.0 ; plunge to 0.028" depth
G1 X1.36237 Y1.38763 F30.0
G1 X1.63763 Y1.38763 F30.0
G1 Z-0.05600 F9.0 ; step another 0.028" to 0.056"
G1 X1.36237 Y1.38763 F30.0
G1 X1.63763 Y1.38763 F30.0
G1 Z-0.08400 F9.0 ; step another 0.028" to 0.084"
G1 X1.36237 Y1.38763 F30.0

The only difference is that first plunge is going a total distance of 0.178" instead of 0.028". We have not updated the firmware since the initial build/setup, but it doesn’t look like there have been any real commits to the firmware repo since 2015. The issue is consistent across OS X (Easel and grblweb), Windows 10 (Easel), and Raspberry Pi (grblweb). We have not adjusted the pots in a while. Would an under/over powered motor cause the inconsistency on the first plunge only?

Could it be a firmware issue? Could it be a zeroing issue? I use the paper technique by lowering Z by 0.1mm until I can no longer pull the paper. That should get me within about 0.1mm (or 0.004") of the surface of the material. Does the X-Carve expect Z0 to be well above the material? I have not tried not raising the bit before carving to see if it is that extra height at the beginning that is causing issues.

We have also had similar issues on the first plunge when using SketchUp + SketchUCam (formerly PhlatBoyz) plugin. We’ve stuck with Easel for all of our recent testing and tweaking since it’s likely to be the best supported option. :smiley:

Thanks to everyone helping to troubleshoot this. As @LesKirk said, we’ve had this machine for over a year now and haven’t really put it to use because the the Z plunge issue. It’s time for us to bite the bullet and get this thing calibrated so it can create sawdust instead of just collect it!

Yes the spoilboard needs to be planed - bit ordered and on the to-do list once this problem is solved. However, we were testing on 1x4 pine no longer than 9". The last few tests were done on 3" x 3" baltic birch ply. The pine was dead nuts .75". Baltic birch is very consistent thickness. The spoil board is not out 1/16" in 9" much less in 3" by any stretch of the imagination. BTW the test pieces were firmly clamped to the waste board. We appreciate your input but I think we are still searching for the answer. Hard to think of all the parameters like board size, etc. to include in the post and we thank everyone for helping us suss this out. Other parameters - 1000 mm model using arduino controller.

1 Like