Error:9 when z-probe is used

We have a cnc4newbies machine with a 7” z-axis.

We have setup soft limits , which works fine when jogging the machine around, but when we use the z-probe function it produces a GRBL error:9 .

We have set the soft limits registers $130,$131 and $132 and $20=1

All seems to work fine except for the z-probe.

Any ideas?

Could this be because of having to pick the acme z-axis in easel because there is no other choice?

It’s been a while since I dealt with this and I had to figure it out myself because Inventables doesn’t think in terms of soft limits being enabled. But when you do a Z probe, the soft limit kicks in and aborts the operation if the total probing distance would exceed the soft limit. So if you start the bit 5mm above the probe and know that the result of the probe wouldn’t exceed the travel limit it fails anyway because the theoretical distance would exceed the limit. So you need to keep the probing distance as small as possible, start the probe from within that distance, and might have to set the Z soft limit higher to give yourself some wiggle room.

1 Like

Disable soft limits/homing for now, retry.
Homing will fault of the travel (seek mode) exceed 150% of soft limit range.

1 Like

Thanks for the response, but I think @StevePrior has my answer.

Thank you for you response, looks like this is this problem.

I’ll see what support has to say.

@HaldorLonningdal and I were basically saying the same thing. His suggestion of turning off the soft limits temporarily just to confirm the issue and get you going (without needing to wait for support’s response) and then you can work out the finer details before turning the limits back on.

Sorry didn’t mean to brush you off @HaldorLonningdal , I had already disabled soft limits before I posted the other day.

Have an amazing Sunday!

Did it work when you disabled soft limits? If so then you can work on the maximum probe distance as I mentioned above.

Yup, soft limits all work if you jog machine around, it is just z-probe . As soon as it initiates it throws error:9

So I would assume you are correct.

I meant did you try probing with soft limits disabled?

Yes, works fine.

We run our machines avg. 6 hours a day so downtime isn’t really an option :wink:

We have had the machine for a while now but I have two jobs that are bigger than the machine coming up this week and thought it best to spend a bit of time to tune it up and setup soft limits. Save crashing and breaking something.

I completely agree and use soft limits myself, but you asked a question and I’m walking through the steps of troubleshooting it. It does appear what I first said is indeed the issue.

1 Like

Steve,
I have a Sainsmart 3018Prover and have the same issue when I use the probe. The Z-Axis travels towards the upper limit switch, stops and the motor makes a rattling sound for approx 4sec and than shuts off.
I get an error 9 - homing error.
I have disabled the soft limits, started the probing sequence 2 mm above the plate, but the same result. I also increased the soft limit 132 from 34 to 38. Same result. Since the Z axis is first to be homed in the Homing sequence, I can NOT use the machine right now.
Any suggestion would help,
Thanks Juergen Mader

Your Z-switch dont detect your Z-axis.
Either its wired incorrectly or the Z-axis is prevented to actually trigger the switch.

Open Easel, press CTRL+SHIFT+D to open Machine Inspector
On the MI-panel there will be a LED icon for your homing switches, press each switch by hand and if detected the icon will turn green.

Soft limits values do not matter.

JuergenMader

have you resolve your issue?I have the same issue, z axis travels towards upper limit switch whenever z-probe command is used, triggering error 9. Z-probe used to work before when i don’t have hard limits switches. Homing doesn’t have any issue, only have problem whenever i used the z-probe

Thanks
Dan Palugod

Hi Dan, does the machine jog properly?

Such as Up moves z up, and z down button moves it down?

Hi Seth, yup no issue with machine jog, no issue going up and down. Could it be the gcode command im using?

G91G21G38.2Z-20F100; G92 Z1.020; G0Z5M30

This used to work without issue before i installed the hard limits for homing, also enabled the soft limit function as well

Well the z probe command looks good as long as the z probe is 1.020mm thick.

Depending on which controller board you’re using and which version grbl is in use and if it was updated when you added the limits, i know the shield controller had to change the pinout when grbl gets updated to any grbl version above 1.1f (i think, it may have been e or higher)

However this shouldnt cause the z to travel up immediately at the start of a probe sequence.

Can you post your grbl settings?
Also what model cnc is this?
Did you also update grbl when you did the limit switch install?

***Ohh just a thought. IF the probe is plugged into a 2 pin connection backwards that might cause the issue youre having maybe.
If you detach the clip from the bit. Hit probe does it go down like its supposed to? (You can then touch the clip to the probe puck by hand to stop it from continuing to lower if needed)

Hi SethCNC

Tried swapping the 2 pin connections didnt help. What i just realized is when i add the hard limit switch for Z. The machine zero is further up, if the the Z axis is sitting at a machine position of -40 and
you tell the Z to move -20 it will move up rather than down. I moved the probe close to the area above the touch plate and then set zero on the Z axis at that point. Then run the probe routine. it worked :slight_smile: Thank you so much for the input and ideas

1 Like

You’re not working in machine coordinates.
The G91 sets the motion modal to relative. Your command tells it to prove down 20mm from where you are.
When it moved up originally, how far was it going?