ESHAPEOKO Software problems (cutting in the wrong place) (SOLVED)

Hello

i have my Eshapeoko all running but with some issues i don’t know if my issues are related to easel I’m using easel as it very easy to use but as my machine is an ESHAPEOKO not a Shapeoko i wonder if easel isn’t compatible but it does carve but it carves in the wrong place than on my screen i have tried changing the movement so it moves 1mm no less no more but it doesn’t make any diffrence.When i go to setup my machine i have slightly different specs than the shapeoko 2 easel lists to choices of machine size 500 and 1000 but my machine is 700 by 700 could this be a problem ? i usually chose 500 also it doesn’t cut to the desired depth that i select on easel its about 2-3mm out sometimes more also easel lists ACME or m8 threaded rod for the Z axis Mine is a trapezoidal looks like ACME is this a problem ? i don’t have homing switches.Maybe i should use different software anyone got any recommendations? i use mac but considering getting a windows laptop. I have used maker cam to make a circle then set tool path etc then sport g code the load onto ugcs set it to cut then the z axis goes up moves into position then cuts in the air i think that could be something I’m doing but not sure ?

it’s so annoying as i just want to turn on and use it

i hope you can help

Dan :slight_smile:

That is quite a story, basically an eShapeOko equals a ShapeOko equals an X-Carve
I expect you use Grbl v0.9 on your controller
In order to verify the working of your machine you need UGS 1.0.9 Do not use the nightly build 2.0 unless you want to be part of the development cycle.
Connect UGS to your controller and list your settings with the $$ command, check these values against the X-Carve default settings
Then check if you are working in inches or mm, goto manual control and move each axis 10mm, verify direction, and length of movement. Adjust wiring or step dir and if distance is not correct number of steps per mm.
When you can move the machine in a 10mm cube without problems you are ready to use easel.
The machine size should not be a problem
Easel will send all necessary parameters to your controller and should work flawlessly

Erik Thank you i am using grbl 0.9 and ill use mm i just checked my ugs and its a nightly build one so ill change that! and ill check the settings when i get home and report back :slight_smile:

where can i find the x carve default settings ? and how do i change mine to them?

heres what easel settings are

ok
$132=100.000 (z max travel, mm)
$131=290.000 (y max travel, mm)
$130=290.000 (x max travel, mm)
$122=50.000 (z accel, mm/sec^2)
$121=250.000 (y accel, mm/sec^2)
$120=250.000 (x accel, mm/sec^2)
$112=500.000 (z max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$110=5000.000 (x max rate, mm/min)
$102=188.976 (z, step/mm)
$101=85.100 (y, step/mm)
$100=100.000 (x, step/mm)
$27=1.000 (homing pull-off, mm)
$26=250 (homing debounce, msec)
$25=250.000 (homing seek, mm/min)
$24=25.000 (homing feed, mm/min)
$23=0 (homing dir invert mask:00000000)
$22=0 (homing cycle, bool)
$21=0 (hard limits, bool)
$20=0 (soft limits, bool)
$13=0 (report inches, bool)
$12=0.002 (arc tolerance, mm)
$11=0.020 (junction deviation, mm)
$10=3 (status report mask:00000011)
$6=0 (probe pin invert, bool)
$5=0 (limit pins invert, bool)
$4=0 (step enable invert, bool)
$3=2 (dir port invert mask:00000010)
$2=0 (step port invert mask:00000000)
$1=255 (step idle delay, msec)
$0=10 (step pulse, usec)
$$
ok
[0.9j.20150930:]

enter link description here
In this post you find some
Seems your x and y steps/mm are way off standard to change, z just a little so do’n bother untill you are ready to calibrate.

To set a vlaue: $100 = 40 enter
$$ for report

Other settings follow: enter link description here

Hopefully you can jog 10mm cube after this

Thank you will try tomorrow and report back

This might even work better:
Go to the Inventables website, support tab, X-Carve, Grbl, Inventables fork, 0.9j ShapeOko2 defaults

That should give you a good baseline to work with, The Z axis may be off a litle but the X and Y should work normally unless your pulleys are different.

I’m getting 404 not found when i select this one

when i select the generic defaults i get a list of numbers

if i go into the archives shapeoko 2 i get a list of numbers swell

Well, forget that and return to the original plan.

So your starting point is an assembled eShapeOko with a running Grbl 0.9j and UGS 1.0.9

What electronics do you use?

this is what i have electronics wise it was kindly assembled for be by the maker of the eshapeoko

you can view the electronics here
http://store.amberspyglass.co.uk

if my pulleys are a different size to the shapeoko 2 will that have an effect i believe mine are this but will have to double check

my one

shapeoko 2 lists this one

The movement of the steppers is defined in Grbl with the number of steps per mm and the settings of the Gaups shield defining the number of microsteps.

Goto gaups setup
scroll down to gShield/grblShield Compatibility and set your dip switches to be compatible with the gShield.

What type of belts/ pulleys do you use, GT2 or MXL

Set the following to:
$100= 40.20
$101= 40.20

Values for 20 tooth pulleys

i have added some pictures of pulleys have you seen ? and i’m at work atm but ill be home in about 2 hours and report back

16 tooth is smaller than the 20 tooth so 1 revolution will take you less far, for 16 tooth you take
40.20 * 16/20 = 32.16

so do i put $100=32.16 $101=32.16 in easels settings