Everything i cut is undersized

Everything I cut is smaller than it should be. Usually by around .5mm. I have read everything I can find posted by people with similar issues.

I have gone through all my V-wheels, pulleys, and idlers. Everything appears good.

I have checked tension on all belts.

I have tested the Voltage on the steppers and adjusted them accordingly.

I have calibrated the steps and during testing they are spot on.

I have measured my bits with calipers just in case they are undersized.

I have tried all kinds of cut parameters. Fast, slow, deep, shallow…

I usually draw up my design in a vector program like Inkscape and import them into easel where I then set them up to be carved. I thought maybe my issue could be their but I have checked every files dimensions. Everything is correct on that front.

I notice during my endless testing and adjusting that the Z axis if given a little pressure really isn’t very stiff. So do you guys think maybe the problem is the axis is to flexible? But then why is everything always smaller wouldn’t it sometimes be larger? I don’t know guys I think I am fatigued from trying to solve this issue. Should I consider a Z axis upgrade or am I missing the solution somewhere else?

If you are cutting “on path” you will likely lose some of the intended area. Try designing a small square using Easel, cut outside path and see if the results are similar. Just a thought.

1 Like

For scenarios like this I suggest you stay within Easel entirely in order to rule out post processor or CAM issues.

Say, design a 50mm and a 250mm pocket in Easel, carve them both.
Are they both having 0.5mm discrepancy?
If yes, there is runout/defelction occurring or incorrect path/bit diameter used.
If no, the smaller part have less discrepancy, then you need to refine / calibrate your steps/mm with greater precision.

1 Like

Quite possibly you need to select “outside” instead of “on path”.

Thanks for the responses guys. I have been cutting outside the line so it’s not that. Last night I got serious and really started taking things apart on the Z axis and found some issues. Mostly some of the bolts had worked their way loose. I got all of that fixed. While doing that I realized my router bit was not square to the machine. I was able to get that corrected as well. I’m going to take HaldorLonningdal’s suggestion and make something in easel only and try that. I’ll post later my findings.

1 Like

I have run into something extremely similar. I ran a test carve of a 1" and 4" blocks (outside, using easel). Since both measurements were the same size off, it wasn’t an error in calibration (steps per inch). After confirming that easel was generating the correct gcode output (by calculations), I was able to determine that there was nothing wrong with either easel or the xcarve machine itself – which resulted in the only cause being a slight difference between the width that my bit actually carves and what it measures up as on a micrometer. I now test my bits by doing the 1" 4" block carves and calculating from that what the actual bit size is, and entering that manually into easel. Problem solved.

Your solution may vary.


Well after many hours trying to fix the problem I have failed. The y axis is better and measures very close to accurate but the X axis is always undersized. I calibrated all axis they are all spot on when testing but once an actual carve starts it’s right back to the same results. I have tried adjusting my IPM and DOC but it doesn’t make a difference either. Everything is very level and square after all the work I did this weekend but the machines performance hasn’t improved. I tried many different bits and again same undersized results.

There is one thing going on I didn’t mention and that is the left y stepper makes a weird thumping sound when the machine first powers up and then it seems to settle in or something and it stops. I don’t know if that is normal or why it would effect the other axis coming up short. Also I notice the X stepper seems to make a very faint hissing sound that none of the other steppers make.

I know the suggestion of fudging the bit size is one possible work around. But honestly I didn’t spend this much money to have to lie to the machine for it to work right. Shouldn’t have to do that on an almost 1.5k machine IMO. I don’t mean to sound like I don’t appreciate the suggestions from the community because I truly do. My frustration is with the company I payed a lot of money to. I’m really depressed about not finding a fix after so many hours trying and the potential financial loss I’m looking at.

Yet another update. I tried fudging the numbers and the part came out exactly the same amount to small. Bummer.

and another update. So I had been using some hickory I had during this whole thing. I know it’s a very hard wood. Since I was trying everything. I threw in some MDF and it cuts out the correct size.

To bad products made from MDF aren’t in very high demand these days.

Have you checked the belt tension? Possible that due to the harder wood, causing it to skip a tooth.
I believe there is some threads in the forum about belt tension, and best ways to confirm it. I used a method I read on here with a fish weigh scale.

1 - Not uncommon when two motors share one axis. Using bump stops when powering up will give you a consistent “lock” between the two Y-motors.

2 - This is due to switching direction of current in the coils, and is unrelated and not harmful in any way. Just physics :slight_smile:

If your machine is squared, trammed, skimmed and calibrated, yet one axis is not cutting correctly its due to backlash/slack/or something loose. Mechanical issue of some sort.
The max precision an nicely tuned Xcarve, in stock form, is supposed to achieve is stated to be around 0.1mm +/- 0.05mm
Its very easy to have less precision :slight_smile:

1 Like

Thanks HaldorLonningdal. You set my mind at ease about the steppers.

I’m betting it’s XY torque in your z axis from radial load. That’s what is happening in mine. I get the same .5mm undercut in dimensions as you when cutting anything harder than ultralight MDF. Even with very light cuts and slowed right down. Sharp tools and powerful spindle. And I can twist the Z assembly just about that much with my hand measuring with a test indicator. Little more play in the X than the Y. The play is all in how the spindle plate is attached to the carriage through the makerslide. Not slop – the wheels are tight. I see it as the give between the softer Delrin wheels and the V rail + torque on the Makerslide. It’s a garbage design. The spindle axis sits way too far out from the carriage and give so much mechanical advantage to radial leverage. I’m in the middle of replacing the whole slide with a linear bearing setup that halves the distance from the carriage, having stiffened up the Y axis with 3/8” plate to get rid of Z and X deflection happening there.

My step calibration is spot on over 700mm with nominally zero backlash. No steps being lost or belt skips. Belts are tensioned to exactly 5.1 lbs @ 1”.

Try this:

Instead of a profile cut, mock up some test dimensions and just plunge some scratch points with an engraving/vcarve bit. No XY cuts, just Z.

Or hot glue a fine line marker to your machine and draw some measurements. Something that excludes the drag on XY.

If the measurements between points are good (they were for me), it’s most likely twist in your Z assembly when under load. I’m betting your machine returns to exactly the work origin after a job too, right? If so, you aren’t losing steps.

And if all the above tests confirm this, throw away the Z assembly that’s on there and buy or make a proper one that’s coupled right to the gantry carriage.

I agree that for for $1500USD it’s disappointing that you have to put so much work into fixing deficiencies. I don’t expect it to be what a $5K or $10K machine would be, but for the same component cost as what comes with the Z assembly out of the box, it could be a much better design. Had I known, I would have bought it without the stock Z slide and simply bought a readymade bolt-on proper slide.

After many hours I can confirm the z axis has a lot of flex and that is where the under cutting is coming from. It’s not lost steps. As you said the machine returns to it’s original home position exactly.

So I have ordered a new Z slider from cnc4newbie and hope this fixes most of the problem. It will probably be here in a week or so. Not to happy about spending another $250 just so the machine is capable of what it was already advertised to be though.

The cnc4newbie slide looks good. I think there are a few good reviews of it from users here.

I was originally going to use a design like that CNC4N slide as a replacement for the XC Z assembly. But I wanted to get as close as I could to the gantry carriage than with round rails and bearing blocks, so am using these pictured below on a 3/8" plate bolted right to the carriage. With the backing plate, the spindle mount will be offset only 21mm and the spindle centre offset only ~60mm from the carriage face. Should minimize the leverage for X axial twist on the gantry and be plenty stiff with the backing plate + the hardened linear rails + the precision and preloaded bearing blocks. These aren’t cheap Chinese bearings. They are super smooth and have no discernible play. Looking forward to (and hoping for) a whole lot more precision.


Just for interest’s sake, here’s one of the ways I tested the XY accuracy and came to conclusion that it was radial load on the Z axis that was causing the undercutting. .03 fineliner on a .001 plunge. Dimensions are spot on. Little concern where the entry and exit overlap, but that might just be an artifact of the lead in and leadout. The machine is pretty square within a few thou over 1000mm, so don’t think you would see that present over a few inches. I did this test in Easel with the op set to “on path”. I would expect it to not run outside the path, but I don’t use Easel all that much. I could control the lead in and leadout with Fusion360, but that’s for another day. Maybe it’s nothing.

Just an update. I fixed my machine and it now is cutting spot on for me. I went and got the cnc4newbie 6" slider. Installed really easy for me I had zero issues other than coming up with a mod for my dustshoe. The Z axis is so much improved now.

Yah so I got ahead of myself when I said it’s fixed. It’s not. Still cuts everything undersized. Even with the new z axis.
On top of that the machine loses connection constantly.

What are your belts tensioned at?

Between 3lbs and 3.5 lbs all the way around.