F-engrave file problems

Thanks for reading this to begin with. I can save a gcode file (ngc) to my computer and then close f-engrave. When I open up f-engrave program again I am unable to open the previous file I just created (or any). No error message just stays with the file it opened with (config file I think). Any ideas?

I am having the same problem. I create and save a g-code file to a folder. I can go to UGCS and it runs fine. I go back to F engrave and open a different bitmap file, calculate and save it as g code in the same folder as before. I then go to F engrave and attempt to open the first file by using “Open F Engrave G Code File”. After a moment the interface flashes like it is doing something but nothing changes. The 2nd object I created is still on the screen - not the first.

I am obviously doing something wrong. Any suggestions?

Have you tried upgrading your F-Carve version. I just loaded V1.62



Yes I have upgraded to the latest version. Been messing with this some more but still can’t get it to load the previously created files. I am at a loss.

How about getting the values to load from a saved config file? I’m on a windows machine, and it doesn’t seem to work if I save the file to either my user directory, or the directory that the program file is in.

I have also been having difficulty getting it to open .ngc files as the OP has. I will try saving the files in the same directory as the original image file.

Edit: Seems like I have done something that has changed that - I’ll keep messing and see if I can update it further and have that “take”.

I have tried every suggestion offered but none of my four Windows 10 systems will load the saved G-code file back into F-Engrave. I just gave up and now note the settings and rerun the whole thing each time I need to go back to the same project. Really like the app but not being able to reload is a major PITA…:weary:

OK, here is a crude video. I open a BMP file and then calculate for Vcarve and then save the gcode back to the same folder where the bmp is. (The gcode runs fine in UGS.) I then open another bmp just to clear the screen. Then try to open the gcode file I just saved. Won’t open! Obviously I am doing something wrong. Any suggestion what that is?


Same here.

Sorry about that - first YouTube post. Screwed that up too! I think it is now Public.

Scorch gave me the answer on the YouTube post.

"Opening previously saved g-code files only works if the “Supress Comments” option was unselected in the “General Settings” when the g-code file was saved. This weird behavior but is the result of a fix for another larger problem. The functions need to be clarified but I am not sure how I am going to fix it yet."

Thanks Scorch! That was all that was needed to make it work.

BTW - Love the app…

1 Like

Excellent! Thank you for sharing that answer - that fixed it for me too.

And yes, I love the app as well.