F-Engrave on OSX

Thank you for the super detailed write up!

After following all the instructions and running into no errors I was hoping I would be fine. I changed most things to 1.54 as that is the latest build of f-engrave. Nothing has been moved from downloads to applications however and when I try to open the .py file after unpacking the .zip it opens in x-code but no program actually runs just a text box with version updates ect…

any thoughts on where I went wrong?

Terminal Saved Output (3.1 KB)

Youhad lots of typo’s between 1.54 and 1.52 which was very confusing…
Anyway, try what you did over and but do not type any tick ` marks (the key to left of 1).
You basically got stuck in bash shell on line 38 of your terminal output.
FYI tab complete will auto complete file names and make the typo’s less as well.

As @JeremyJohnstone said, you have an unmatched quote at the end of line 38 which put you into a multi-line command mode in bash. That’s why you got a ‘>’ prompt on each line rather than your normal ‘YourMomsMacbook:’ prompt. Run through the process again but watch your quotes.

I got F-engrave working with Wine. But is there a way to export g-code from F-engrave that works on Easel?
Thanks in advanced

I’ve used ChiliPepper with success (http://chilipeppr.com) but I don’t think Easel had the g-code import option at the time. You could probably start a new thread with your g-code attached if you’re seeing odd behavior in Easel.


There is no need to run F-Engrave in WINE.
The program runs in Windows, MacOS X, and Linux.
Maybe you have some strange exception which is why you are running it in WINE.
There are several methods to send the g-code:

  1. Easel - Turn off Arc fitting inside F-Engrave first
  2. ChiliPeppr
  3. UGS (Universal G-Code Sender)

I turned off the Arc Fitting option, but I still get this error when I try to import the code to Easel :confused:

Inside F-Engrave’s G Code configuration area, get rid of the G64 and P0.001 commands.
They are not needed.
More details when using Easel:

FYI I used to have a Z move command in my configuration so the spindle doesn’t start while touching the stock surface.
I don’t remember if you need to add a Z move command when using Easel.

Update: If this is still too confusing, use the other two options like already mentioned! :slight_smile:

1 Like

Is it just me or does F-Engrave run R E A L L Y - S L O W L Y on a mac? I watch the tutorial vids and his PC version seems to scream through the V-Carve plotting whereas mine just sort of plods along at its own pace. I’ve not no slouch of a machine, it’s an 3.4ghz i7. I’m thinking it’s just XCode being slow.

I also see a lot of weird font errors in the interface. Words break out of dialog boxes, or only the top half is in the button or visible. It’s like the text is too big for the interface, but moving the window boundaries doesn’t do anything to fix it. It seems like it was built to use a different native font than what OSX uses.

I can’t see what I’m doing wrong here… I have downloaded the updated link and I have opened it in Terminal

Last login: Thu Apr 7 17:02:33 on ttys003
Kriss-MacBook-Pro:~ kcrawford$ /Users/kcrawford/Downloads/mac-f-engrave-157-terminal\ 2/run-f-engrave.sh ; exit;
python: can’t open file ‘/Users/kcrawford/f-engrave-157.py’: [Errno 2] No such file or directory
Saving session…
…copying shared history…
…saving history…truncating history files…

[Process completed]

Do I need to jump back in at a specific step? Any help would be so appreciated

Change into the directory:
cd /Users/kcrawford/Downloads/mac-f-engrave-157-terminal\ 2

Start script:

This should work.

F-Engrave tries to use “psyco” for speedup. Don’t know if psyco is available for mac. It is also unmaintained. Maybe the script could be improved with pypy for all platforms. Any python pros out there?

    import psyco
    sys.stdout.write("(Psyco loaded: You have the fastest F-Engrave.)\n")

@ChristianSonntag Sweet! That worked. Thanks for the support.

I can get Fengrave to run, but I can’t get it to use PNG files (and it doesn’t read my text from the DXF files from Inkscape). I don’t know enough to figure out how to make this work on my Mac…?

PNG files probably need an auto-tracer installed.

Text in DXFs would require the exact me font to be available to both the DXF app, and F-Engrave — I just made a custom font and did the cutting from that.

I found that using Pixelmator I can export to a BMP file and F-Engrave will open that. I also didn’t have any luck with PNG files but I didn’t put much effort into trying to get them to work. For the few carves I had to do it was easier to convert my image to BMP.

1 Like

To package F-Engrave for macOS could use this guide: https://www.metachris.com/2015/11/create-standalone-mac-os-x-applications-with-python-and-py2app/

1 Like

Followed this step by step and worked great. Thanks

Hi. I have made a bundled macOS app with all needed files in it using Playtypus. Included is the current f-engrave-162.py python script and all compiled binaries (potrace & ttf2cxf_stream).

You can download it here: http://www.motions-media.de/download/f-engrave-fuer-mac-v1-62/

1 Like

No fonts loaded :frowning: