Inventables Community Forum

Fail in upload HEX

Dear fellow Carvers,

Unfortunately I have a problem with uploading a new HEX to my X-Controller of my X carve. I have done a lot of reading and testing, however I do not succeed. To use the laser in combination with the PicEngrave software I want to upload a new hex. However via Xloader with Windows 10 (via bootcamp an my macbook), via HEXLoader via IOS, via Xloader on a windows 7 laptop, via IDE on both systems and via Easel I cannot get it done.

Or the programms freezes or I get messages like below.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

Can someone give me a hint?

Just answered you here:

Here are some basic Xloader instructions to make sure you are setting it up correctly.

is your baud rate set to the highest

Thank you for the comments. I have read the instructions and have tried it again. Unfortunately it didn’t work. I have tried it with a route of 115200. Also have tried it with higher and lower values, both on my usb port and in the Xloader programm.

I hope there are more ideas!

Can you control your machine with Easel, but the .hex load fails, or do you get errors with both types of access?

From your message I can see that you tried more than one USB connection, have you tried a different USB cable?

Yes that is wat surprised me. I can control my machine via Easel, via UGS and also via Picsender. But when I wat to upload a new Hex I can’t.
I did’t try a other cable. Have search if I have one at home. Keep you posted.

That means that the USB cable is ok.

Just to cover all bases, try a different .hex file and see if that works. Which .hex file are you trying to load?

Found two and tested them. Same result. I can control the machine but uploading fails. Both my windows pc as my macbook have the same results.

Is the board in a Xcontroller really a Arduino uno?

No. It is an Arduino look alike(not a clone but a re-design), but not an official Arduino Uno.

Many people have programmed the X-controller with Xloader using the hardware designation in the image from the instructions I linked to.

Have you made any modifications inside the X-controller?

Inside the X-controller is a header block labeled J3. If there is a wire hooked to that header make sure that it is plugged in with the correct orientation and is seated well.

If there is no wiring hooked to that connector (may be normal - that connector has the programming signals on it and it may not need a wire - it can be used with an external programmer) then you are going to need to get in touch with Inventables to see if you need a replacement circuit board for the X-controller.

It is a X Controller original without any modification. The only difference is that I bought it by RoboSavvy because I live in Europe. I will check the connector tonight.

1 Like

I have checked it. The connector is on without wiring. I will get in contact with inventable. Hopefully we will get it fixed and I will share the solution.

It’s a strange problem. If you had an external programmer we could try that, but hopefully RoboSavvy will work things out for you. If not, then get in touch with Inventables, so far they have been excellent in their handling of hardware problems.

After some mail back and forward, Inventables addressed it as a corrupt boot loader. So the board needs te be exchanged. This morning I send a mail to Robosavvy. Hopefully they act as fast as Inventables.

Can’t wait to laser carve my first picture ;). Thank you for all your input