Feed rate while not cutting is too fast

I just updated my X-carve to the newest version. The feed rate when the bit is not cutting (just moving from one cut to the next) is quite a bit faster than the feed rate that I set for the machine. The feed rate I set works when it is cutting just not for moving. This is causing some issues. First, the spindle is moving fast enough that it is actually scooting around my whole machine when it stops, obviously this cold be an issue. Also I think it is moving fast enough that the stepper motors are skipping on the belt? Or maybe just can’t keep up? I’m not sure. But I know it is messing up my carves, when it goes to the next cut the bit is not where it is supposed to be. Is there a way to change this feed setting?

Could you post your settings? $110 and $111 are your speed.

…and $120/121 is your acceleration values

I was thinking maybe his belts we’re not tight if machine is losing position.

I will look at the settings when I get home. You are talking about the settings in the g-code correct, not the Easel settings? I have never had a problem with this before, I have been using the x-carve for over a year now and have never had any belt slipping issues or v wheel issues. I would prefer to just slow the feed rate down while not cutting. I am guessing that’s not as easy as I first thought, probably have to do it in the Arduino?

You can view/change those parameters through the Machine Inspector window in Easel.

CTRL+SHIFT+D brings it up.
In console type “$$” and hit enter. A complete list of your current GRBL-settings will appear.

I guess your:
$110 and $111 values = 8000 (max feed rate, mm/min)
$120 and $121 values = 50

To change any parameter simple in console write:
for instance “$110=4000” and hit Enter
Reset system to make sure change takes effect, verify with a $$ command.

Thanks! I will try this tonight and report back.

So it is normal for the spindle to move fast enough to scoot the whole machine around the table? Granted it is a plastic top but still seems too fast to me.

My table shakes during carves if there are abrupt changes in travel direction or the rapid moves. An example would be when jogging in one inch increments.
I have my machine fastened to table. I have never lost position with exception of crashes that were my fault.

Interesting. You would think the people programming this would factor in that it is a small machine and set the rates accordingly. I understand this code is probably generic for a lot of stsytems but you could still keep that in mind. I will check the belts and v wheels but I will still probably turn the speed down. I don’t see any reason to put unneeded stress on the equipment to save a couple miniutes per carve. If I was doing production work I could understand wanting the speed.

I just checked my settings:

$110 & $111 = 8000.000
$120 & $121 = 500.000

Others confirm please, isn’t the Xcarve acceleration defaults = 50?
(I dont have an Xcarve myself)

Acceleration @ 500 is very quick and the sudden change may in fact tax the belts and position somewhat.
Try $120-22 @ 50
This will soften the acceleration quite a bit and make the system move more smoothly / less aggressive.

I set 120&121 to 50.000 and played with it. That seems about the speed it was running at before the update. After I updated the arduino is when it changed to 500.000 I currently have it set to 200.00 and have ran some test cuts and everything seems to be working fine at that speed. No moving the machine around or skipping steps.

1 Like

I understand the concept of momentum. That is not the issue, the issue is that it is running at a speed that causes momentum to be a problem.

Your’s seems to be the only one of hundreds, if not thousands of machines that behave this way.


I agree. The machine had work perfectly for over a year, then after the update I was having the issues. I set the accelerating rate to 200.00 and it seems to be just fine again. What are everyone else’s $121 & $120 rates? Are they all 500.00?

Just read this thread again.

Updating is not always a good idea.

As a rule, unless the new version has something I really want, or someone holds a gun to my head, if I have a working system, no update.

One of a thousand reasons I don’t use Easel.

1 Like

I think I am going to have to start doing the same! All is good for now. Thanks to everyone for the help!

I recently updated to grbl 1.1F and have had no issues and noticed no change in rates. My settings are as follows.