Final Setup well sort of

Installed gcode, arduino driver and all loaded up. Opened Ugcs located the machine movement tab tried to jog the machine …and nothing. By the way not using Easel I have vcarve.

Run the machine setup in Easel first to set the variables.

Once you do that open UGSC (after closing Easel) choose the correct COM port and the speed set to 115200 then hit connect or open…whichever it is…lol

Well there’s a bit of another issue and thats with easel. Long story short is I logged into easel once and thats all I’ve ever been able to do. It’s been a back and forth unresolved fix.

So How do I set variables any other way?

Can you connect with UGS?


I’m not at my machine, so I can’t look at my settings, they are on the forum somewhere…on the command tab of UGS enter $$ this shoes your current settings.

enter $1=255 (just an example) for each setting and you can do them one at a time.

I’ll need to take a look at that when I get back from work tonight.

Start here:

So this will apply to the 1000th also? And how do I get to the portion to change all this?

There are some differences with the 1000mm unit, most notably $130 and $131 which are used with soft limits. I have seen systems with these parameters set to 790 for the 1000mm unit.

You can change the values in UGCS in the “Command Tab”. To change a value just enter the number you want to change and the value for it. If you want to change the report mask you would enter something like $10=19 or $10=3 depends on what you want it to do.

Depending on how you wired your machine you might have to change $3 and $23. These are not different on the 500 and 1000, but might need to be different to make your machine move in the correct direction for the jog controls and for the G-code you generate in your CAM program.

Also, if you have homing cycle turned on, Grbl will come up in the “Alarm” state and will not respond to G code until you do a homing cycle or clear the “Alarm” with $X (be careful with this as Grbl doesn’t know where your spindle is without homing).

Well I’ll give it a shot in the morning and see how it’s gonna work. This has all been greek to me but willing and wanting to learn as much as I can.

Sounds good.

To save some time and typing start with the Grbl command $RST=*

That will cause Grbl to reinitialize with the parameter settings that were in effect when the Grbl code was generated. I can’t remember right now when this was implemented, but I’m running v0.9j and it’s in there.

Also, some more info if you want to get down and dirty:

PS we are all learning Greek - it just take a little while :smiley:

Tired that a couple times in the command hit enter and nothing. Port shows Com 3 baud rate is 115200 and it’s open

Yeah, UGCS doesn’t send everything through. You may need to use the Arduino Serial Monitor or a terminal program to use all the Grbl commands.

Fixed the issue!!! Just used a newer laptop and all worked out.

Ok, great.

I think last thing. I just sent a tool path and i started to “air Carve” in what looked like normal speed.
Canceled the carve re postioned lower on the board and now it’s in tiny movements.

Check to make sure that your design and carve are in the same units (inches or mm). If you are getting small movement you may have designed in inches and carved in mm.

Check your Grbl parameters to make sure they are reasonable (or post them here and I’ll take a look).