First attempt at 3D carving

I made my first attempt at 3D carving this weekend.
It was not entirely successful but I learned a lot. :smile:

First, while doing a simple carve in Easel I had some slipping in the Y axis. After carefully watching I saw that it was only on one side.
Checking that side and sure enough the eccentric nut was loose.
So I got some Loctite blue (which confused me because it comes in a red tube?)
I adjusted the belts, pulleys and eccentric nuts, using Loctite this time. :wink:

Then I made a carve file in VCarve and loaded it up into Chillypepper.
I was having a lot of problems with chillypepper. I could jog the axis and send the gCode but was not getting positional info back from the machine. In my messing around I managed to crush my Z Axis home switch. oops! Damm totally my fault. :frowning:
But finally I sent the gCode and it carved really weird. It was a series of seeming random straight lines, nothing like the file or the preview in chillypepper.
I stopped the print, but could NOT figure out how to clear it from memory.
So I pressed the reset switch on the GShiled and reloaded chillypepper.
I recalculated and saved the cut file and tried again.
Same weird lines. So whatever is going on it is consistent. I let the file play out to what it would do. It started to make a move that would crash the gantry into the end, so I did a E Stop and reset.

I switched to UGS and tried a third time.
The file printed correctly!
Unfortunately I was using slow, default speeds so the print would take hours.
I watched it for about a hour to make sure everything was fine then worked on other things.

At some point a shift up in the Z axis happened. :confused:
I checked the stepper and it was VERY hot to the touch. That indicated there was a lot of current running through the stepper. Not enough to hurt it as their safe operating temperatures are too hot to touch. But I might be casing overheat issues in the drive chip. So I dialed back the Z Axis current pot a bit.
The V Wheels seemed a little tight as well. I will have to adjust those.

The print finally completed. While I was waiting I went into VCarve and adjusted the feed speed on my tool library so it will cut at a more reasonable speed.

After giving it some thought I think chillypepper might have been using relative addressing instead of absolute.
So I will modify my VCarve post process files to add a “G90” to the start of every cut file and see if that fixes the problem.

So to do list for tonight’s attempt:

  • Recheck all v wheels and eccentric nuts
  • Update VCarve Post Processors with “G90” (Use Absolute Addressing)
  • Get bigger shop vac for dust collection (such a mess!)
  • Read up on how to use chillypepper
  • Order new limit switches (Get a few spares)

Don’t you just love complex systems!

What were you carving? My first 3D carving was the Eagle from the Animal clipart files in Vcarve. I was amazed at how well it turned out.

Nice to see you know what’s going on, what needs to be done. This is the learning curve.
Yes V-Wheels are very important for accuracy. I didn’t use red bottled blue Loctite, I tide them crazy, my wheels are very hard to turn by hand and not giving me any problems. Belts are the another important elements. Needs to be tide enough. I was post earlier for protecting Z home switch you may want to take a look at.

1 Like

It was a Tiki Face clipart I bought from Ventric’s Design and Make website

@AlanDavis Cool Z Stop! I will be doing that ASAP.

1 Like

I found the issue with the z axis. My end mill was slipping!
I managed to get a better print. The bigger shop vac made a big difference but I need a better dust shoe. As well as to add some dust shields to the Y rails.

There are still some issues. Some slipping / shifting during the print as well as some chipping of the MDF.
I need to tweek my print setting. And try this with some real wood.

I also noticed a lot of flexing in the X gantry. I have the supplies for the stiffing mod. I will try that next.

Made the updates to the post processor.
Chillypeppr is still freaking out. Here is a picture of what it is doing. The lines are not random, it is the same pattern each time. It is just reading the inputs weird.
I am not sure what is going on, but UGS works fine :slight_smile:
I wiill probably wait until chillypeppr is updated before giving it a try again.

1 Like

Awesome Tiki Carving!

On Chilipeppr which JSUN Server were you running? If you are using Windows and GRBL workspace you need the Version 1.80 not the latest version as it does not work. Seems like my issues were sort of similar to yours. But I love chilipeppr now. I need to go browse Vectrics library ASAP.

I should be running 1.80. I will double check it
I would love to get Chillypeppr running because I want to do rough cutting / finish cutting and using a touch plate to adjust for the bit height between carves would make things so much simpler.

[quote=“AaronMatthews, post:7, topic:12035”]
I want to do rough cutting / finish cutting and using a touch plate to adjust for the bit height between carves would

I need to get this setup as well. I ran a successful carve with a bit change just this weekend. Thankfully! I had to Zero Z with good ole fashioned paper method. But it worked for me.

I ran this with Chilipeppr with a Clearing Tool and then V-Bit.


I did another carve with the Tiki model last night.

I upped the Y axis current to “max” (turn it up till the steppers started to vibrate and do weirdness the back off a bit)
No Y axis slipping. :smile:
I original started with a scrap piece of plywood but I did not have it clamped down well enough and it slipped free mid carve!

I used some bamboo flooring samples
1/8" ball nose
1400 mm/min

Bamboo Laminate (from Home Depot, $0)

and Solid Bamboo (from Lowe’s $0.25)

I am having a bit of difficulty with VCarve getting the model height and cut depth right.
The carve is not cutting as deep as I want. It seems to be off by about 2mm.

I checked and the Z axis is moving the correct distance. So the step rate is properly calibrated.

I am not sure if it is a software setting or waste board leveling issue.

You can rule out the second one by taking a piece of scrap and pocketing an area, then placing your work material in the pocket and carving it. That’s what I do when I have a piece that I need to be 100% level.

Looking carefully at the carves there are several traces where the Z height was off maybe by 1mm or less but it left noticeable traces or in some cases gouges.
The thing in these spots are consistent with each carve.
Different materials, different compiling of the g code. No artifacts visible in the code previews. It seems to be a mechanical issue in the XC.
There is a lot going on. Flex in the X gantry, runout in my cheep bit adaptor, possible backlash in the Z screew.

So I cut my steel bar and slipped it between the X rails.

OMG did that make a huge difference! I clamped it in place and tightened the X gantry screws down. Surprisingly that seems to be enough to keep it in place. I left a clamp on (clear of the work envelope) until I can drill and bolt it properly.

The next carve did not have all the weird “tracings” so gantry flex was probably my culprit for that.

It still has issues, but I think they are software / operator related.
This carve has a nasty gouge down the center.

This is from the initial cut. I realized that with VCarve when you do a finish carve it does not do the carve in “layers” so in some sections the cut depth was 8 times the bit diameter! The “gouge” area being a full bit width cut on top of that.
So rough cut first, even if I don’t change bits!

There are some smaller areas where the bit would change direction in the spiral carve pattern. A noticeable seam.
More flex maybe? Cutting a sane thickness may eliminate that too, If not I may try doing a raster carve and see if that corrects the problem.