First Cut Failure - Connectivity & Calibration Issues :'(

Hi - I’m new. I just put together my machine over here in Merída, MX and everything is mechanically sound.

I have a newer model with a Z-Probe and homing switches. I installed the Easel driver “.3.10” on my computer (OSX El Crapton or whatever they’re calling it now, the latest one).

I guess this is kind of a multi-issue thread so I’ll try to go through the process -

After OSX driver was installed, I continued along the Easel machine setup process. Everything went fine with connecting, but the motors were all responding inversely - I am 1000% certain my wiring is correct (I can recite the pattern from my head for the motors, left to right - X = R,W,G,B > Y1= R,W,G,B > Y2 = R,W,B,G > Z = R,W,G,B). So I let the software redefine it automatically.

Went through the homing process fine, then the Z-Probe process was a little strange. It connected up but the actual setup process is weird…when you touch the plate to the tip to check the circuit closes and allow you to continue, nothing happens when you hit continue. It just takes you on to the next step. So I restarted the process and then went to the Advanced section before continuing, and it allowed me to do a test probe there. That worked, but does that actually set your machine? I don’t get it…

Anyway, I went onward, my machine home location displays as -798,-798,-6 or something like that (instead of 0,0,0 ?). I assumed this was from having to reverse the motor directions, so I leave it and go to do a test carve with everything setup correctly.

The router bit’s home position is lower than my material, but I assumed it’d raise itself up before beginning…I was wrong. It just swung over and took a bite and knocked a clamp off before I hit the red button on top of the X-Controller.

NOW, I am trying to re-connect to the thing and it just hangs saying “insert USB and turn on machine” when it’s already connected and running. I am really annoyed about this, I’ve tried turning off and on, re-installing driver, etc. Nothing is bringing it back.

I should note that before doing the carve, Easel brought me into a new window to double check my settings were correct…and then asked me again if I wanted to do my z-probing, so I selected manual because I was confused…anyway, what am I supposed to be doing here. I’m sure my understanding of the z-probing process is the cause of the issue here, but I really can’t get the thing connected again.

There was also a message about there being new firmware for the machine that disappeared when I pressed carve. I can’t find that again, or where to do it. I think I need some directions here…

I have the same set up, and the motor started reverse as well, its not an issue, after reversing the first time homing it will remember the correct direction.

the Z-probs I assuming you’re talking about the set up while homing, that just checking the connection. when you are actually doing the cutting it will ask you to do the touching again then it will ask you to put the brass piece on material and the machine will run z until the bit touch the brass piece. … oh ok the next paragraph tells me its while cut set up. so Z position set up theres 5 steps and the 4th step said touch the brass to bit and when you do it the light goes green, then allow you to next step. after doing that, you place the brass piece on your material hit the last step( something about lowering bit or probing) then the bit will lower to that brass piece then it will be calibrated.

after you hit the emergency button you have to twist it until it jump back up, if you don’t do the the machine power won’t lit up, the fan would be running thats the only thing has power goes through

hope that help

1 Like

I actually fixed my dumb mistakes, you were correct! I’ve cut my first piece, and even after calibrating the z-axis properly, it still came through to the wasteboard a bit, which is annoying.

Everything was set to the defaults in Easel (for the correct piece and material) and the cut depth was set to about 47/64" with a piece that was 49/64". I am immediately noticing issues that I would like to address by programming it manually to get a good chip load and use specific specs to my bit and collet - I can do this with Fusion360, but will bringing the gcode into easel force me to use their tool settings or will everything just get sent over untouched?

I am still kind of upset about the wasteboard getting cut though because I calibrated the z-axis correctly and set the correct bit and cutting depth, so I can’t see what the issue is there. That’s a couple 64ths of an inch too far - I suppose I’ve gotta do some more research…

You know what, I didn’t do that - I just assumed that Easel had a standard for the brass pieces and they were all machined exactly the same. I’ll check tomorrow and see if there’s a difference, thanks.

Yeah I was dumb and assumed I’d get my z-axis flawlessly calibrated the first time around - I saw a couple videos of people cutting right down through the thickness of their material directly on their wasteboards and not making more than a scratch on them, so I thought I could just do the same.

I’ll get the hang of everything I suppose.

Home position (not your HOMING position) can be anywhere within the work space of your machine.

Gcode imported from Fusion360 will promt Easel to act as a sender only, no Easel tool settings/feeds etc will be carried over.

You have Homing Position ($H) left, and towards you correct?

  • Machine Zero (XYZ0) will be upper right corner.
  • Since the Xcarve is a carver, aka remove material the work space is in the negative domain.
    Carve => remove => subtract.

This is good news - I did all this research on chip load/rpm/feed rates and immediately realized I wanted more control over the thing. Now to find out about getting an automatic spindle control on this DeWalt 611…

Yes, it is right up front and to the left - so everything seems to be order if I’m understanding correctly now? I cut a couple gears to start and the dimensions are so precise, I’m very happy with it. I just had a little freakout when things didn’t go flawlessly to start, but as usual with these things…it was the user.