First problem with easel

Tonight I attempted to create a project in easel that required multiple lines of text. The first line went in okay, the second a little slower, the next line even slower and so on and by the time I was down 7 lines of text easel would die on me. Has anyone tried doing multiple lines of text while in easel and if so did it work okay for you?

easel crashes on me frequently as well, i’ve been looking into other options

I’ve not had a problem until I attempted multiple lines of text.

Hi @JamesMitchell I made a multiline text carving and it worked.

Can you please share the file so we can investigate?

I will try.

Zach, I’m sorry but the file I was working on I deleted and tried again with a much shorter file. I attempted to ‘share’ it under the easel file pull down, I don’t know if it went out to you though?

[quote=“JamesMitchell, post:6, topic:11012, full:true”]
Zach, I’m sorry but the file I was working on I deleted and tried again with a much shorter file. I attempted to ‘share’ it under the easel file pull down, I don’t know if it went out to you though?
[/quote]Zach, I was attempting to do a carving of the ten commandments using easel. I clicked on the ‘text’ pulldown and started typing with a return at the end of each commandment line. The first line went in ok, the second line a little slower, the third line slower still and the text would take a long time to register on the page. By the time I got to the seventh line easel was crashing on me. I would reset and try again but easel just keep crashing. Should I have not tried to type so many lines of text under the one text pulldown?

Try downloading https://inkscape.org/en/. Use this tutorial https://www.youtube.com/watch?v=pmT9YDLnMHI and save your text as an svg, then reopen in easel. This can also get you on the road to picking up greater capabilities in design, file production, etc.

edit: I forgot to say click ‘path - object to path’ before saving.

Thanks Jeremiah, but dang it, it should work in easel!

okay guys, here’s the deal. I don’t know if it’s me or this dang xp computer, but I’m through trying to do stuff on it until I get my windows 7 software uploaded and the xp computer upgraded. I am tired of fighting this dog and not accomplishing anything. Like I said, it could just be me, we will know soon enough!

What I like about Easel is the gui simplifying the CAM and sender process while I am new or for simpler jobs. Creating svg files and the expanded capabilities of Inkscape seem like a good next step out into the process, depending possibly on where someone is at or what they are intending to do.

Here are a couple of more tutorials for inkscape that may be helpful or of interest as well: https://www.youtube.com/watch?v=obOebZkBwW8, https://www.youtube.com/watch?v=q8XORGTMjIs.

In case it had not been noticed with my previous post, I added an edit where I forgot to say to click ‘path - object to path’ before saving, to make a usable svg in inkscape. Although, I do not know a lot beyond that at this time.

edit: I find this tutorial a bit more informative for getting into simple cad design etc. through inkscape: https://www.youtube.com/watch?v=GuvvO6TELt0 (oops, accidentally wrong link at first.)

Hi @JamesMitchell,

I’m sorry about the problems you ran into. Just to clarify, are you saying that carving slowed down as the machine moved from one line to the next, or that Easel’s interface became increasingly laggy the more text you had in your design?

Jeremiah, I tried what you said and ‘easel’ told me it couldn’t upload text as an .svg file? So now what? I tried loading inkscape file with another extension but then I couldn’t get easel to recognize that file. So I am still batting zero.

Yes, easel’s interface would not allow me to type multiple lines of text. With each successive line of text, easel would get slower and slower until it would not respond at all.
I have not yet been able to type a multi line text string with easel. Example; 1. type text., return, 2. type text., return, 3. type text., return and so on and so forth. Try it, let me know what you get.

@JamesMitchell, I’m not sure what the problem is. I always do tests to see if I can do something first.

It should be viewed as a ‘scalable’ graphic technically. You have to make sure the text is ‘selected’ when you click ‘path’ - ‘object to path’ before saving in Inkscape. When you save it, it should say Inkscape or Plain .svg.

Then in Easel, ‘file’ - ‘Import svg’ should open something. I haven’t done anything different than that, and only tested a few things with fair luck so far.

Thanks Jeremiah, as I’ve said, I am new to all of this even though I have a cad background getting to know a different software package can be daunting to say the least.

I agree and usually just try to get a useful operation down and build off that or learn others if they are very different.

Then I can design or work within my capabilities to that point, and try to learn more to increase my capability, etc. at the same time.

Jeremiah, you say you’ve successfully created text in inkscape and uploaded it to easel? I to was able to upload a string of text, 10 lines of it, from inkscape into easel but when I tried to do the toolpath easel froze up on me and would not go any further. Have you experienced this?

I’m still just testing, but have not had any problems like that. I’m not sure if you have seen this, but here is a similar new thread: Trouble with Easel and SVG files

Zach just emailed me today and yes they found a problem with easel on this multi lines of text thingy and they are in the process of fixing it now. So should be able to do multiple lines of text in easel soon! :smiley: